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1 Overview

1.1 What is Master Planner?

Master Planner is a graphical version of a wall planner, presented as a grid, with names of
resources, such as employees, down the left and dates across the top. A planner may show a
number of weeks, or a whole year, or you can specify exact dates. Add icons to grid squares to
indicate the activities of employees on selected dates - holidays, project work, conferences and so
on.

Each resource has from 1 to 12 lines for icons on the planner, for activities during different time
periods. For each resource, you can specify start, finish and birthdates, if required, and assign them
to categories defined by you. A wide range of icons is available, from which you can choose just the
ones appropriate to your company. A text note may be added to any grid square to record additional
information.

Floating toolbars give access to editing functions and moving around the planner may be achieved
using mouse or keyboard operations. An undo function is available. A status bar, tooltips and full
on-line help make Master Planner easy to use.

For larger planners, you can view a specific category, or a group of resources, or search on a
number of categories at once, eg all male staff with more than 20 years experience. The statistics
function shows the number of times an icon has been used for a time period. Icon tracking allows
you to control how much an icon is used, for instance when scheduling staff leave or training.

Planner information may be printed as shown on screen, as individual schedules or showing text
notes, and full backup and restore functions are available.
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1.2 The planner screen

Figure 1 : a view of the main planner screen, showing all toolbars docked

2 Installing

2.1 Obtaining Master Planner

The latest version of Master Planner is available for download from the Ross Software at
www.ross-software.co.uk. The download file is a self-installing executable; once downloaded and
saved, navigate to the file in Windows Explorer and double-click to begin the installation process,
which will install the program, online help and sample files.

You may also buy a copy of the program on disk for backup purposes and to facilitate installation to
a new machine; contact Ross Software (how? ) to request a disk.

2.2 Technical requirements

Master Planner is 32-bit software, so it only runs on Windows versions from 95 onwards. It will not
run under Windows 3.x or macintosh. Installation is by self-installing executable. You will need
approximately 6 Mb of free hard disk space. A minimum of 32 Mb of RAM (memory) is
recommended. As with all graphical programs, a faster machine improves performance - 200 MHz or
better is recommended.

Master Planner can be connected to almost any standard inkjet or laser printer. Planner sections will
print in colour, as displayed on the screen.

30



Master Planner 4 - Network Administrator's Guide 3

© 2005 ... Ross Software

A planner may be any size from 4 to 150 weeks (almost 3 years), with no theoretical limit on the
number of resources. For standard style planners, the date range may be adjusted at any time, so by
removing out-of-date weeks and adding blank weeks at the end of the planner it may be used
indefinitely. You may also create additional planners; select the calendar-year style to create a
separate planner for each year.

2.3 Licence conditions

When you install Master Planner in either the Standard (single-user) or Network (multi-user)
versions, you agree to the licencing terms set out below. The demo version is the Standard (single-
user) version, but with some reduction in functionality.

End user licence agreement:

This licence permits you to install Master Planner as follows: (Standard version) one copy on a
single computer for the use of only one person; (Network version) one copy on a network server
and/or multiple copies on other computers for the use of no more than the number of licenced users
shown on the registration certificate. Each user may additionally install and use Master Planner on a
second computer for use outside the office, provided that the total number of users does not
exceed the number of licenced users. A user is defined as any person who uses Master Planner to
view, print or update files, even occasionally. You may make a copy of the setup disk(s) for backup
purposes. You may not disclose any registration keys issued to you to anyone outside your
company. You may not rent or lease Master Planner, but you may transfer your rights on a
permanent basis provided you transfer the software and all related materials, including previous
versions, and retain no copies, installed or not, on any computer or removeable media, and confirm
such in writing to Ross Software. The liability of Ross Software shall not exceed the price paid for
the software.

Master Planner is owned by Ross Software and is subject to international copyright laws. The
intellectual rights reside with the programmers Pauline M Ross and James G Ross Jr. It is not
permitted to reverse engineer, decompile or disassemble Master Planner.

Valid at the date of release; contact Ross Software (how? ) for the latest version, or further
information.

2.4 Upgrading from earlier versions

You can install Master Planner 4 to the same location as an existing installation if you wish, or you
may choose to install separately (the default). The program will read planners created in earlier
versions, but planners saved in version 4 format will not be readable in earlier versions of the
program. As with all software upgrades, you are advised to take secure backups of all planner and
toolbar files before upgrading. You should always upgrade using the full setup program, and not by
copying the version 4 executable; this ensures that the supporting files are correctly installed and
shortcuts set up.

Upgrading the Network version: network administrators are advised to test Master Planner 4 on a
stand-alone machine (not connected to the network) before a full roll-out.

For your convenience, version 4 includes a number of features to make maintenance easier:

· A network administrator's maintenance tool, allowing full customisation of client installations,
easier management of planner files and live monitoring of Master Planner users.

· Easy creation of automated client installation files.
· Version 4 can save planner files in version 3 format, enabling users not yet upgraded to version 4

to continue to have access to planner data. This feature should be used cautiously, as saving in
version 3 format may cause some loss of data (for instance, if additional categories have been
added).

· Automatic installation of future upgrades.
· Automatic updating of registration keys.
· Master Planner user's personal settings are now saved to the registry for the benefit of

companies using 'hot-desking'. Settings may be exported or imported, for convenience when
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existing users need to reinstall to a new machine.
· No run-time files - once installed to the server, client machines may run Master Planner simply by

creating a shortcut to the program on the server (a full client installation is still recommended to
ensure consistency and to create shortcuts in the Start menu to the sample and help files).

2.5 Finding out which version you have

To find out about your current licence status, select About Master Planner from the Help menu.
This will show whether this installation is the Demo, Standard or Network version; the number of
licenced users at this location; and, for temporary registration keys, the expiry date of the current
key.

You can also see the company name, location and customer number, if you have entered this
optional information. The company name and location are displayed on the startup (splash) screen,
and the customer number will help Ross Software to trace your company's details if you need
technical support.

The About screen also shows the program version which is currently running (for example,
4.0.0.44); this information will help Ross Software if you need technical support.

You can print a copy of the End User Licence Agreement.

2.6 Installing the network version

2.6.1 Network installation options

There are two possible options for installing Master Planner to a network for use by multiple users:

1. Network + client installation Install the program to the server (network installation) and allow
all client machines to access the program on the server (client installation). This method allows
for easier maintenance, as upgrades to the program or new registration keys need only be
installed to the server.

2. Stand-alone installation Install the program individually on each machine (stand-alone
installation). This method allows users who work from home or travel to other offices to
continue to use Master Planner, but maintenance is a little more complicated. Automated
upgrades are available for users who access shared files on the server, but users who only
use Master Planner for local files will need to be upgraded manually whenever a new version
of the program is released or your registration key changes (for example, if you increase the
number of licences). Note that if you do not install the program to the server at all, you will not
have access to the Network Administrator's Utility Program, which assists with maintenance
and manages automated upgrades in a multi-user environment.

Of course, it is also possible to have a mixture of client and stand-alone installations. In all cases,
shared planner files can be stored on the server, or users can create their own planner files and
store them on their local machine.

See also:

Network version maintenance
The network version maintenance tool
Entering a registration key

2.6.2 Installing the network version: a summary

Here is a brief guide to the recommended steps for installing Master Planner to the network; read
the following sections for more detail. Before you start, make sure you have:

· The Master Planner setup program, either downloaded from the Ross Software website at
www.ross-software.co.uk or on disk.

· A registration key valid for the Network version of Master Planner; users will not be able to
access the program or planner files on the server without this.
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Installation steps:

1. Install the program to the server: run the setup program, selecting Network options, then
Installing to a network server. This will install all the Master Planner program files to the
server, in a directory of your choice, and will create the subdirectories StandardSetup,
AutoSetup and NetAdmin.

2. Copy the setup program to the server: copy the setup program to both the StandardSetup
and AutoSetup directories.

3. EITHER Install to client machines: select a client machine and rerun the same setup
program, selecting Network options but this time selecting Setup client to run program
from server. You will be prompted for the program directory, and to select which desktop and
Start menu shortcuts you require. You will also be asked to enter your registration key. This will
enable access to Master Planner from this machine. Repeat this process for all client
machines.

4. OR Set up automated client installation (recommended for large numbers of
installations): open the network administrator's utility program (netadmin.exe in the NetAdmin
directory) and select the Automated client installation tab and click the Create or edit
configuration file. A wizard will guide you through the process of creating a settings file
(client.txt) for running automated client installations. Save this file to the AutoSetup directory.
From each client machine, you should then browse to the AutoSetup directory and run the
setup program. Client installation will then run automatically without requiring responses from
you.

6. Set permissions (trustee rights): Master Planner data (.mpf) files should be restricted using
your own network software to read/write (users will be able to edit planner data); read-only
(users will only be able to view and print planner data, and editing functions will be disabled); or
no access. In addition, all Master Planner users must have read/write access to all
network user (.usr) files; these files list all active users for each planner data file and the
program itself, and help maintain data integrity in a multi-user environment. Later, you may
want to restrict access to icon toolbar, custom icon or auto-updating files. (More )

7. Run the Network Administrator's Utility Program: this small program (netadmin.exe in the
NetAdmin directory) will store details about Master Planner installations, and assist you in
managing and maintaining the program. It is recommended that you complete the Directories
and Installations list pages now, and familiarise yourself with the program functions.You may
want to copy the program and its data file (netadmin.ini) to removable media for ease of use, or
for maximum security remove them from the server.

See also:

The network version maintenance tool
Access rights for planner files
Access rights for Master Planner directories

2.6.3 Installing the program to a network

Run the setup program. When prompted, select the Network option, then select the Installing to a
network server option. This will install all the Master Planner program files to the server. You may
also set up the installing machine as a client machine at the same time, if required.

It is recommended that you now run the Network Administrator's Utility Program (How? ) which will
simplify the task of client installation.

When you have installed the program files to the server, you may set up additional client machines
(How? ), or you can install the program to client machines (How? ) if the user may need to run
Master Planner when not on the network.

Warning: if you fail to enter a valid registration key, or you have purchased only the Standard (single
user) version of Master Planner, you will not be able to run the program from the network server.

See also:

Entering a registration key
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Network version maintenance
The network version maintenance tool

2.6.4 Client installation

2.6.4.1 Client installation: options

Before installing a client version of Master Planner, you should have previously installed the program
to the server (How? ).

There are three methods of creating client versions of Master Planner (that is, setting up a machine
to run the program from the server):

1. Manually create a shortcut on the desktop or in the Start menu to run the program from the
server. (More )

2. Customise the client installation by running the setup program from the Master Planner disk or
a copy downloaded from the Ross Software web site. (More )

3. Run the automated client setup created by the Network Administrator's Utility Program.
(More )

2.6.4.2 Manual client installation

You can quickly set up a machine to run Master Planner from the server by manually creating a
shortcut on the desktop or in the Start menu. Browse to the directory where you installed Master
Planner on the server, and create a shortcut to 'mastplan.exe'.

You now need to enter the registration key and set a default planner file to open when Master
Planner starts. Click the new shortcut; you will be prompted to enter the registration key. Once this
has been entered, you will see the Welcome screen; you should browse for an appropriate startup
file, click Preferences in the Options menu and click the Startup tab. Tick the default file checkbox
and click OK.

2.6.4.3 Custom client installation

The client installation process can be individually customised for each user. To do this, run the
setup program from the Master Planner disk or a copy downloaded from the Ross Software web
site (How? ), and, when prompted, select the Network option, then the option to Setup client to
run program from server. The client installation will create desktop or start menu shortcuts
selected from a list.

You can also create shortcuts to existing planner files, so that these will be opened automatically
when the user clicks that shortcut, or you can select an existing planner file to be run automatically
when Windows starts on this machine.

The client installation also allows you to enter a registration key; this unlocks all the features of the
network version. If a valid registration key has already been entered on this machine, you can leave
this section blank.

If you need to repeat the client installation process for multiple users, and want to ensure that the
same options are set for each user, use the automated client installation instead. (How? )

2.6.4.4 Automated client installation

If you need to install Master Planner to a large number of client machines, the client installation
process can be automated. First, ensure that you have installed Master Planner to the server
(how? ). Now run the Network Administrator's Utility Program netadmin.exe. Select the
Directories tab, and ensure that all the server directories are correctly shown. Now select the
Automated client installation tab, click the Create or edit configuration file and a wizard will
help you set options. Finally, make sure a copy of the Master Planner setup program (setup.exe or
mpsetup.exe) is in the same directory as the client installation configuration file (client.txt) - this
directory is usually called AutoSetup. (More )
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When you want to run an automated client installation, you simply run the setup program from the
AutoSetup directory; it will obtain all the settings from the client.txt file and silently run the
installation, requiring no intervention from you. Of course, you can run client setups from any
directory, but the client.txt file must be present in the same directory for automated client installation
to work.

See also:

The network administrator's program

2.6.5 Stand-alone installation

Rather than install the program to the network and run user machines as clients, you may prefer to
install Master Planner to each machine, and simply share files on the server. Or you may have some
users who access the program on the server while at the office, but occasionally need to run it while
away from the office. This requires a stand-alone installation, which will install the program and all
subsidiary files on that computer.

Run the setup program. When prompted, select the Stand-alone installation option. Alternatively, if
you have the program disk, the setup program will autorun when the disk is inserted into your CD
player.

Enter the registration key, without spaces, when prompted during the installation. Without a valid
registration key, the setup program will install an unregistered (evaluation) version of Master Planner,
which has some features disabled. To enter a registration key after installation, run Master Planner
and select Register Master Planner from the Help menu; type in your company, location,
registration number and registration key, and click OK. Master Planner is now ready for use (some
versions of Windows require administrator's rights for installation).

2.6.6 Reinstalling on a different computer

When a user with a stand-alone installation acquires a new computer, you will need to install Master
Planner on the new machine and migrate all the planner files and settings. Here are some tips to
help make the process as painless as possible. If you have any problems or questions, contact
Ross Software for assistance (how? ).

Before you start, you will need:
· The program disk, or the setup file (download the latest version from www.ross-software.co.uk

or contact Ross Software to buy a copy).
· The registration key you were given when you purchased Master Planner (contact Ross Software

if you have lost the key). If you have multiple keys, check which is the latest by typing it into the
Update registration key tab of the Network Administrator's Utility Program.

Step 1: install the program
Insert the program disk in the drive (it should auto-run), or start the setup file. Select the Stand-
alone installation option, and type in the registration key, without spaces, when prompted.

Step 2: move planner files
Transfer all planner files from the old machine to the new one. These may include:
· Planner data files (these usually have a .mpf extension)
· Icon toolbar files (if you have saved the list of planner icons separately, these will have a .tlb

extension)
· Any custom icons bitmaps used on the planner files

Step 3: transfer personal settings
On the old machine, run Master Planner. Select Export/Import from the File menu, and click
Export personal settings. All the user's personal settings, including display preferences, default
options, recent files and personal reminders, will be compiled into a configuration (INI) file. Save
this file and transfer it to the new machine.

This file is a simple text file, which can be read in Notepad (or any text-editing program). Note that
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file paths are saved in full, so if you have stored planner files in a different location on the new
machine (for instance, in the D drive instead of the C drive), you may want to edit the INI file by
hand. Otherwise, some file settings may not transfer correctly.

Now run Master Planner on the new machine. Select Export/Import from the File menu, and click
Import personal settings. Browse to the saved file location. Your settings will now be saved to the
registry of the new machine, and applied immediately.

Step 4: uninstall from the old machine
If all is working correctly, it is now safe to uninstall Master Planner from the old machine. Browse to
the Master Planner directory and run unwise.exe; all program files will now be removed. You will still
need to manually delete the Master Planner directory and any planner files. Note that registry
entries (for personal settings and the registration key data) will not be removed; if you need to do
this, contact Ross Software for instructions BEFORE uninstalling.

2.6.7 Access rights for planner files

When you have installed Master Planner to the network and set up client installations, you may wish
to set permissions (trustee rights) to ensure that only selected staff may edit planner files. This is
done using your own network software. In normal operation, Master Planner uses some or all of the
following files:

Network user (.usr) files:
A network user (.usr) file is created for each planner (.mpf) file on the server, and also for the
program (.exe) file itself. These files are used to monitor the number of licenced users, and to
protect data integrity by recording the identity of the currently editing user. You must ensure that
all Master Planner users have read/write access to all network user (.usr) files. If for any
reason you are unable to set permissions for individual files (some Novell users have encountered
this problem), create a text file, mastplan.nov, containing the path (with no trailing backslash) of an
existing directory where user files may be stored, and put a copy of this file in the Master Planner
program directory and any directory containing planner data (.mpf) files; trustee rights may now be
set for the user files directory.

Planner data files (usually .mpf):
Allow read/write access to staff with editing rights; they will be able to change any planner data.
Allow read-only access to other staff, who will be able to view or print planner data, but all editing
functions will be disabled. Deny access to users not allowed to use Master Planner on the network.

Icon toolbar (.tlb) and custom icon data (.dat) files:
The list of icons (symbols) which may be used on a particular planner may be saved seperately
from the planner as an icon toolbar file. It is recommended that access be restricted to read-only for
most users. Note: custom icon data (.dat) files are not used in version 4.

Custom icon bitmap (.bmp) files:
If you have created custom icons, you may wish to restrict access to these files for most users.

Auto-updating (.mpk) files:
These files are used to trigger automatic user upgrades when program files or your registration key
are changed. You should allow read-only access for most users.

Auto-updating log (.mpk.log) files:
These files are used to record automatic user upgrades when program files or your registration key
are changed. All users must be able to write to these files.

2.6.8 Access rights for Master Planner directories

The network installation of Master Planner initially creates 4 directories by default:

· Master Planner 4: contains the application files, including the program (mastplan.exe), the help
files (mastplan.hlp and mastplan.cnt) and some sample planner (.mpf) files. Read-only access is
recommended for most users (but note that all users must have read/write access to the user file
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mastplan.exe.usr).
· StandardSetup: for running manual client or stand-alone installations from the server; you

should place a copy of the setup program in here. Read-only access is recommended for most
users.

· AutoSetup: for running automated client installations; you should place a copy of the setup
program in here and create a settings file (client.txt) using the Network Administrator's Utility
Program (how? ). A sample file is included for reference. Read-only access is recommended
for most users.

· NetAdmin: contains the Network Administrator's Utility Program (netadmin.exe) and its data file
(netadmin.ini). Read-only access is recommended for most users, or you may wish to move
these files to removable media for maximum security.

See also:

Network installation options
Network administrator's utility program

3 Planner files

3.1 Saving a planner file

To save any changes made to the current planner, click Save or Save as on the File menu. If Save
as is selected or this planner has not previously been saved, the standard Windows directory browse
dialog will be shown to enable a save location to be selected. The status bar below the planner will
indicate that the planner has been saved successfully.

There will always be a prompt to save any unsaved changes before closing Master Planner, or open
a different planner.

Changes can also be saved automatically, using the AutoSave  feature (select User preferences
on the Options menu and click the Global tab). When activated, the planner will be saved without
prompting according to the setting: on exit; after every change; every 5 minutes; every minute.
This applies to every planner opened. For shared planner files the AutoSave function only operates
when the planner is open for editing (the traffic light shows green).

3.2 AutoSave option

This is an option which enables a planner to be saved automatically. To set AutoSave, select User
preferences from the Options menu, and click the Global tab. The current AutoSave setting is
saved in the registry with other personal settings, and applies to all planners opened. When a planner
is automatically saved, a message will be shown in the right portion of the status bar below the
planner.

There are 5 settings:

· Off: the planner will only be saved when you request it (you will be prompted to save any unsaved
changes before opening a different planner or exiting the program).

· Save on exit: the planner will automatically be saved when opening a different planner or exiting
the program (there will not be a prompt).

· Save on change: any changes you make will be saved immediately.
· Save every 5 minutes: the planner will automatically be saved every 5 minutes and when closed.
· Save every 1 minute: the planner will automatically be saved every minute and when closed.

3.3 Opening a planner file

Any number of planners may be created. When Master Planner first loads, the default file will
normally be opened automatically. There are three ways to open a different planner (there will be an
opportunity to save any unsaved changes to the planner already open):
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· Select a recent file: on the menu bar, select File, then select from the list of up to ten recently
accessed planners.

· Use the menu bar: select File on the menu bar, then select Open. A dialog box will appear
showing a list of recently accessed planner files. Double-click to select one, or click the Browse
button to open the standard file dialog box, which will allow a search of the local or network
drives.

· Click the toolbar button: on the main toolbar, click the  button. The dialog box described
above will appear.

If any error occurs while trying to open the selected planner, a message will be shown and the
previous planner will continue to be displayed. You should check that the selected file is in fact a
Master Planner file (the default extension is .mpf), and that the drive where the planner is located is
available (for example, it may have the wrong disk or no disk in the floppy drive, the network may
have shut down, etc).

3.4 The open planner screen

Figure 2 : selecting a planner file to open

3.5 Disabled toolbar buttons (read-only files)

For local planner files, most menu items and toolbar buttons in Master Planner are enabled, allowing
access to all the editing functions in Master Planner. This means that the planner file can be edited,
that is, it is possible to both read the data from the file and write data to it when changes are made.

For shared network files, however, and occasionally for other reasons, toolbar buttons on the edit
toolbar and the corresponding menu options are disabled (greyed out). This may mean that the file is
flagged for read-only (the data can be viewed, but not changed) or that only certain changes can be
made. Possible reasons include:

· There are no resources on the planner. Many functions apply only when there are some

resources - click the  button on the edit toolbar or select Add new resource from the Edit
resource section of the Edit menu. Once resources have been added, many functions will
become available.

· Master Planner is accessing a file from the network server. Network files are normally

opened in non-editing mode. Request editing capabilites by clicking the red traffic signal . This
may be denied if another user is editing the file, or the user does not have editing authority.

· The planner file is read-only because another user has opened the file: only one person
at a time can open a file for editing to avoid loss of data. When a user tries to open the file for
editing, a message will give the login name of the person who is currently editing. When the
other user releases the file, it will be possible for another user to open the file.

· The planner file is read-only because the user does not have permission to edit this file:
shared network files may be set to read-only for most users and only system administrators will
be able to access files for editing.

· The planner file is read-only because the planner is already open in another instance of
Master Planner: if the user has accidentally opened the program twice with the same planner,
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the second copy will show the editing functions disabled.
· The planner file is read-only because the read-only flag has been set manually or left

locked: the file may have been protected because it is a backup or master copy which should
not be overwritten. Occasionally for shared files, the flag may be left on even though no user is
accessing the planner. For local files, you will be asked when you open the file whether you
want to view the planner, or change the read-only setting so that you can edit it. For shared
(network) files, the read-only status cannot be changed in this way; if you are quite sure the file
is not in use, you can reset the read-only flag manually. You can check if the file is in use on
the Monitor users tab of the Network Administrator's Utility Program (netadmin.exe); if the file
is incorrectly locked, the Delete button will delete the user file and reset the read-only flag.

3.6 Advanced file management options

3.6.1 The default startup file

The default startup file is the planner file which Master Planner opens automatically when it first runs.
The first planner created after installing Master Planner will normally become the default startup file.
Each user may have a different default startup file.

To change the default file for a user, first open the file, then click User preferences in the Options
menu and click the Startup tab. Tick the default file checkbox and click OK.

If the default startup file is not accessible or cannot be found, you will be able to browse for it or look
for a different planner to open. To avoid repeatedly needing to do this, you should set a new file as
your default startup file, as described above.

The default startup file specification can be overridden by opening Master Planner using a shortcut
or command line instruction (how? ) or by setting a planner file to be opened automatically when
Windows starts (how? ).

3.6.2 Opening a planner with a shortcut

It is possible to start Master Planner with any specific planner file. This will override the default file
setting . To do this create a shortcut in a folder or on the desktop to the Master Planner executable
and add the required file path to the target in the dialog, leaving a space between the two file paths.
There is no need to put quotes round the second file path. The target will look something like this:

 "c:\Program Files\Master Planner\mastplan.exe" c:\My Files\My Planner File.mpf

This will open the program at the same size and position as the last time it was run. It is also possible
to open the planner minimised to the task bar or minimised to the system tray by using the parameter
/m or /s in the target line, like this:

"c:\Program Files\Master Planner\mastplan.exe" /m c:\My Files\My Planner File.mpf

"c:\Program Files\Master Planner\mastplan.exe" /s c:\My Files\My Planner File.mpf

Alternatively, you can associate the mpf file extension (or your own choice of extension) with Master
Planner. See the Windows Help file or your IT advisor if you need help with these options.

3.6.3 Automatically opening a planner when Windows starts

You can choose to have any planner open automatically when Windows starts up, and you can
choose to open the planner normal size (as you left it last time you viewed it), minimised to the task
bar or minimised to the system tray.

To enable this facility, select User preferences from the Options menu, and select the Startup
tab. Click your preferred option from the choices.
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3.6.4 Shared planner files on a network

The network version of Master Planner may be run from a network server, and files may also be held
on the server if necessary. Any number of users may view a network-held planner at once, but only
one user at a time may edit a file. Use your network software to determine who has read-write access
and who has read-only access. Master Planner will disable editing functions for those with read-only
access. The traffic light button on the main toolbar indicates the status of the current planner:

 Planner cannot be edited; click to open for editing.

 Planner has changed since it was opened; click to refresh.

 Planner may be edited; after making changes, save the file then click to release the planner for
other users to make changes. The changes will be notified to other users (their traffic light will turn
yellow) reminding them to refresh.

WARNING: the file is locked when the green traffic light shows - no other user can edit it. Users
should always release the file as soon as they have finished making changes.

3.6.5 Shared planner files by email

From time to time, users may wish to send planner files to colleagues in other offices or working from
home. To do this, simply attach the planner file to an email. Planner files are small text-based files,
and cannot contain viruses.

The receiving colleagues should have Master Planner installed on their machine, and they will also
need copies of any external files required, such as toolbar (.tlb) files and any custom icon (.bmp) files
used on the toolbar. These may be previously installed, or can also be attached to the email. Each
user viewing planner files, even those without editing rights, should have a licence to use Master
Planner (more ).

WARNING: as with all files, only one master version of a planner file may exist; copies should be
regarded as read-only and no changes should be made to shared files away from the network. The
Master Planner file-sharing functions (controlled by the traffic-light icon) do not operate on copied
files held locally.

3.7 Backup and restore options

3.7.1 Backup and restore: an overview

It is good practice to have a backup procedure for important files. If your company has such a
backup procedure, you should ensure that Master Planner files are included - this may include
planner files (normally these have a .mpf extension), external toolbar (.tlb) files, any custom icon
(.bmp) files you have created, network user (.usr) files and automated upgrade files and logs (.mpk
and .mpk.log files). If you use the Network Administrator's Utility Program on the server, the settings
file (netadmin.ini) should also be backed up. Personal settings are stored in the registry, but may be
exported in text file format for backup purposes (how? ).

If you do not use a company-wide backup procedure, or you have an occasional need to backup
files (for example, to external media), Master Planner has built-in easy-to-use backup and restore
facilities.

Users can also enable one-click backup from a button on the toolbar (how? ) or automate
backups, so that a backup is always taken when closing a planner or before major changes (such
as changes to the planner date range) (how? ).

3
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3.7.2 The backup screen

Figure 3 : setting backup options

3.7.3 Backing up a planner file

To backup a planner, either select File then Backup from the menu bar or click the  button on the
main toolbar. You will be shown the backup dialog window. Click the Browse button to select a path
from your local or network drives. Click Backup to save the current settings and backup the current
file to the selected file path. Click Apply to save the current settings without backing up.

If Quick Backup  is enabled, click the  or  button on the main toolbar; a backup will be made
immediately and a message displayed on the right portion of the status bar below the planner.

3.7.4 QuickBackup

QuickBackup is an option which enables an instant backup of the current planner, using the current
settings, from the main toolbar.

Quick Backup is enabled from the backup dialog - select File then Backup from the menu bar, and,
in the Automatically backup to box, click the Browse button to select a suitable backup path. Then
check the Enable QuickBackup box. Click Apply to save these settings.

The toolbar buttons on the main toolbar show whether Quick Backup is enabled:

 Shows backup dialog window (Quick Backup disabled)

 Backs up the planner now to a floppy drive (Quick Backup enabled)

 Backs up the planner now to a local or network drive (Quick Backup enabled)

3.7.5 Automatic backups

Master Planner can be set to take an automatic backup, either when a planner is closed down or
before changes to the planner date range (this avoids losing any data when you remove out-of-date
weeks from the planner).

Select File then Backup from the menu bar, and, in the Automatically backup to box, click the
Browse button to select a suitable backup path. Then check either or both of the options to enable
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automatic backups.

You can also specify one of two backup file numbering systems to ensure that you keep multiple
backup files, which is more secure than repeatedly overwriting the same file. The limited system
keeps a complete month of daily backups before overwriting, while the unlimited system creates a
new file for each backup and never overwrites (this can create a huge number of backup files).

Click Apply to save these settings.

3.7.6 Restoring a planner file

To restore a planner from a backup copy, select File then Restore from the menu bar. You will be
shown the restore dialog window. Click the Browse button to select a path from your local or network
drives. Click Restore to restore the selected file.

You should verify that the restored file is correct. If you restore a file and find that it is not correct, you
can revert to the original data by selecting Open from the File menu, and selecting from the list of
recent files (it will be the first on the list).

WARNING: the restored file will overwrite the current planner data on screen immediately, but it will
not overwrite the file until it is saved or AutoSaved ; at this point the original data will be lost. This
action cannot be undone. Master Planner will switch off the AutoSave function before restoring to
prevent accidental loss of data; you will then be asked if you want to switch it back on. You should
verify that the restored file is correct first.

3.7.7 The restore screen

Figure 4 : restoring a Master Planner file

3.8 Other Master Planner files

3.8.1 Toolbar symbol files

A toolbar symbol (icon) file is a list of all the icons available for use on a planner. Normally the icons
list is saved as part of the planner data, but it can also be saved as a separate external file for use
with multiple planners (how? ). This also allows permissions to be set for the toolbar file which may
be different from those on the planner file.

You may have any number of toolbar files, saved to any local or network directory. Toolbar files can
be backed up and restored by Master Planner's built-in facilities.

Note that once a planner toolbar is saved as a separate file, the file must be available whenever that
planner is opened in Master Planner. This will become a consideration if a planner file normally held
on the server is copied to a local drive or emailed to a colleague out of the office for use away from
the server.

The location of an external toolbar file is stored as part of the planner data. If it cannot be found, the
program will search the directories of the program and the planner file. If these also fail, an error will
be raised and you can either browse for a toolbar file or use the default set of built-in icons.

If any symbols used on the planner are not on the toolbar, they will display as on the planner and

9
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on the toolbar button.

3.8.2 Custom symbol files

Custom symbol files are bitmap (.bmp) files which have been created for use on the planner symbols
toolbar (how? ). Any custom icons which have been added to a planner toolbar will be backed up
and restored by Master Planner's built-in facilities.

Note that the files for any custom icons included in a planner must be available whenever that
planner is opened in Master Planner. This will become a consideration if a planner file normally held
on the server is copied to a local drive or emailed to a colleague out of the office for use away from
the server.

The location of custom icon files is stored as part of the toolbar data, either in the planner file or as a
separate toolbar file . If any custom icon bitmap file cannot be found, the program will search the
directories of the program and the planner file and any 'Icons' subdirectories. If it still cannot be
found, the icon will display as on the planner and on the toolbar button.

3.8.3 Version 2 and 3 files

Version 4 of Master Planner is able to read planner files created in earlier versions of the program. A
planner created in an earlier version of Master Planner will be saved in version 4 format, and will no
longer be readable in earlier versions of the program. However, a version 4 file can be exported in
version 3.2 format, for the convenience of companies with a mixture of versions during the upgrading
process. This may lose some data which takes advantage of the new features, so it is recommended
that exported files be regarded as read-only and not be imported back into version 4.

To export a planner in version 3 format, select Export/Import from the File menu, and click the
Export planner as version 3. Select a location and file name and the file will be saved in version 3
format.

3.8.4 Personal settings data

Master Planner stores information about a user's program preferences in the registry. This allows
users to move from one machine to another at will, and always have their personal settings available.

Personal settings include:

· Date heading format
· Planner colours
· The default startup file (more )
· The default personal view for a planner
· Automatically opening a planner when Windows starts (more )
· The list of recently-used files
· Personal reminders

and a range of global options, namely:

· Running the program from the system tray
· Warning when icons on the planner are about to be overwritten
· Zooming in or out
· Undo levels
· AutoSave options (more )
· The style of buttons on the toolbars
· The shortcut key system for navigation or highlighting the planner

All these settings can be viewed or changed by selecting User preferences from the Options menu.
See the help file or full manual for more information about these options.

Personal settings data can be exported in text-based (INI) file format for backup purposes, or to be
imported into a new machine. These functions are available from the Export/Import option of the
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File menu.

4 Using your own icons

4.1 Changing the icons on the toolbar

To change the planner icons toolbar, click the  button in the edit toolbar or select the Edit

planner icons list option in the Edit menu (for shared network files, click the  button to open the
planner for editing first). The New symbols toolbar box shows the details of your current choice of
icons. There is a range of available alternatives grouped by type Standard tab, or click the Custom
tab to add a previously created custom icon (more ).

You can:

· Add new symbols to the list (how? )
· Remove unwanted symbols from the list (how? )
· Rearrange the symbols on the list and change their properties (how? )
· Replace one symbol with another throughout the planner (how? )
· Save the toolbar, either as part of the planner or as a separate file (how? )
· Import a previously saved toolbar, either to modify it or to replace the toolbar on the current

planner (how? )

4.2 The toolbar icon editing screen

Figure 5 : changing the list of icons on the planner symbols toolbar

4.3 Adding icons to the symbols toolbar

First open the icon editing dialog by selecting Edit planner icons list from the Edit menu.

Adding standard (built-in) icons: select a new icon from the Available symbols list and drag it
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onto the New symbols toolbar window, or use the right arrow button. You can drop it into any
position, or drag it to a new position.

You can specify that the new icon should apply to an entire column, by ticking the Column box. This
is useful for icons which represent an activity applicable to all resources on the planner, such as a
bank holiday or office closure. When you add a column-wide icon to the planner, all cells for the
selected days will be set to that icon, whether they were in the selected area or not.

Adding custom icons: you can add custom icons using the Custom tab. You should have
previously created pairs of icons (how? ), one to be displayed on the toolbar itself and a smaller
version to be displayed on the grid.  Browse to the location of these bitmaps, specify a description
and select a suitable colour (light/yellow, medium/blue or dark/black) for the flash which indicates that
a planner cell has a text note attached. The icons and the coloured flash will be displayed. Click the
Add button to add the custom icon to the toolbar.

Note that custom icons are kept as separate files, and not stored as part of the planner file. All
users must have access to the custom icon files when using the planner, so this option is most
useful for shared planners held on the server.

4.4 Removing icons from the toolbar

First open the icon editing dialog by selecting Edit planner icons list from the Edit menu.

Find the icon to be removed in the New symbols toolbar window and drag it off the toolbar. You can
drop it back onto the list of available icons, or onto an empty area of the window, such as the space
below the toolbar. Alternatively, highlight it and click the arrow button.

You will not be able to remove any icons which are currently in use on the planner, or which are
being tracked (see the help file or manual for information about icon tracking). If the removed icon
is a standard (built-in) one, it will now be shown on the list of available icons, in the appropriate
group. Removed custom icons will not be shown.

4.5 Replacing one symbol with another

Occasionally you may change your mind about an icon which is already in use on the planner -
perhaps it is no longer suitable, or you want to use it for a different activity. There is no need to
delete all instances of the icon from the planner; instead, you can replace the icon globally with one
that is more suitable.

First open the icon editing dialog by selecting Edit planner icons list from the Edit menu and
highlight the symbol you wish to replace in the New symbols toolbar box.

Now look in the Available symbols window and select a suitable replacement from the list of built-
in symbols on the Standard tab, or browse for a previously created custom icon (how? ) on the
Custom tab.

Click the Replace with selected symbol button. When you save the toolbar changes, all instances
of the original symbol on the planner will be replaced.

4.6 Changing icon properties and rearranging the list

First open the icon editing dialog by selecting Edit planner icons list from the Edit menu.

The current list of icons is shown in the New symbols toolbar window, which displays the properties
of each icon. Editable properties are shown in white (click to change); some properties are not
editable and are greyed out. The properties are:

· Description: click once or twice to edit
· Column: tick to specify that this icon applies to all resources; you cannot change this if the icon is

in use or tracked
· In use: shows whether the icon is already being used on the planner (this is for information only, as
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in use icons cannot be removed)
· Tracked: shows whether the icon is being tracked as part of an icon tracking specification (for

information only, tracked icons cannot be removed); see the help file or manual for information
about icon tracking.

Properties for custom icons:

· Custom: indicates a custom icon
· Flash: shows the colour of the small flash which indicates that a planner cell has a note attached to

it; change this by clicking on it, selecting from light (yellow), medium (blue) or dark (black)
· Path for toolbar bitmap: click to select a different path
· Path for grid bitmap: click to select a different path

Custom icon properties may also be changed using the Custom tab.

Rearranging the list of symbols: highlight an icon to be moved and either drag it to a new
position, or use the up and down arrow buttons.

4.7 Saving a toolbar

When you have made changes to a planner symbols toolbar, you can save the changed toolbar in
one of two ways:

· Save the toolbar as part of the planner file: make sure the Save this toolbar as a separate file
to use with other planners option is NOT checked, and then click the Save button. The toolbar
details will be kept as an integral part of the planner file. You will still be able to copy the toolbar
when you create a new planner file, and either copy of the toolbar may then be modified without the
changes appearing in the other copy.

· Save the toolbar as a separate file: check the Save this toolbar as a separate file to use with
other planners option and click the Save button. The toolbar details will be saved as a toolbar
(.tlb) file, and may be used in multiple planners. Any changes made to the saved toolbar file will
then be reflected in all planners using it when they are next opened. Note that this method allows
the toolbar file to be protected by restricting permissions, so that users with full updating rights to
the planner file may have read only access to the toolbar file.

Note that saving a separate toolbar file does not necessarily update the planner symbols toolbar on
the current planner. This enables you to modify any number of toolbar files without affecting the open
planner. Check the Use saved toolbar with this planner option if you want your changes to update
this planner.

See also:

Changing the icons on the toolbar
Importing a toolbar

4.8 Importing a toolbar

To reuse a previously saved file, open or create the planner you wish to use the toolbar with, and
open the toolbar icons editing dialog by selecting Edit planner icons list in the Edit menu.

Now click the Import  toolbar button and browse for the required file. Ensure that the Use saved
toolbar with this planner option is checked, and click Save. The imported toolbar file will entirely
replace the existing toolbar; however, if any icons on the existing toolbar are in use on the planner
or are being tracked, they will be retained. Any icons on the planner not matching an icon on the
new toolbar will display the symbol .

See also:

Changing the icons on the toolbar
Saving a toolbar
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4.9 What are custom icons?

Master Planner provides a wide range of icons (symbols) for use on a planner. Each planner may
have a different set of icons on the planner toolbar, customised as required. The toolbar data may be
stored as part of the planner file, or saved to a toolbar file (usually with a .tlb extension) for use in
other planners.

You can also create custom icons for use in planner toolbars. This means you can create any icons
appropriate to your company and its activities.

There are two steps required:

1) Create some custom icons, using a standard drawing package capable of producing bitmap
(.bmp) files, such as Windows Paint or Paint Shop Pro. (How? )

2) Add custom icons to a planner. (How? )

4.10 The custom icon screen

Figure 6 : adding custom icons to a planner symbols toolbar

4.11 Creating and using your own icons

To create your own custom icons for use in planner toolbars you will need to use a standard drawing
package capable of producing bitmap (.bmp) files, such as Windows Paint or Paint Shop Pro. It is
recommended that you use the standard Windows 16-colour palette.

You will need to create 2 bitmap files for each icon: a toolbar bitmap (20 pixels x 20 pixels) and a
planner grid bitmap (18 pixels x 10 pixels). For the toolbar bitmap, you can set part of the image to be
transparent; the transparency colour is the colour of the first pixel in the saved bitmap (usually the
bottom left corner of the image). The grid bitmap does not use transparency. The icons should be
saved to a location accessible to any planner using them.

Once you have created some icon bitmaps, you can add them to the toolbar of a planner.
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Select Edit planner icons list from the Edit menu, and click the Custom tab. Browse to the location
of the saved bitmaps, specify a description and select a suitable colour (light/yellow, medium/blue or
dark/black) for the flash which indicates that a planner cell has a text note attached. The icons and
the coloured flash will be displayed. Click the Add button to add the custom icon to the toolbar.

Note: once custom icons are added to a planner toolbar, the icon bitmap files must be available
whenever that planner is opened in Master Planner. This will become a consideration if a planner
file normally held on the server is copied to a local drive or emailed to a colleague out of the office
for use in stand-alone mode. If any files are not available, they will display as  on the toolbar
and/or planner.

5 Network version maintenance

5.1 Network version maintenance tasks

5.1.1 Adding additional users and changing the registration key

When you first purchase Master Planner, you buy a licence for a specified number of users. The
program will restrict access to the program and planner files to this number of users. If you want to
increase the number of users, you must pay the additional cost. You will then be given a new
registration key, valid for the new number of users.

The new key must be entered into all existing installations to allow the new number of users access.
There are two ways to do this:

· Manual update: on each computer with Master Planner installed, run the program and select
Register Master Planner from the Help menu. The new key can now be entered.

· Automated update: enter the new registration key in the Network Administrator's Utility Program
(netadmin.exe in the NetAdmin directory). This will automatically update the machines of users
whenever they access either the program on the server, or any shared planner file on the server.
Note that this will only be effective if you have previously entered information about the program
directory and planner file directories to the Network Administrator's Utility Program. You can
check which users have received the update by checking the mpk.log files in the Master Planner
program and planner files directories (on the Review update logs tab in the Network
Administrator's Utility Program).

Finally, you can install Master Planner to the number of additional machines permitted by your new
licence. For a manual installation (stand-alone or client), the new registration key can be entered as
part of the installation process. For automated client installations, the new key will be entered
automatically.

See also:

Installing to a network
Client installation: options
The network administrator's program
Entering a registration key

5.1.2 Entering a registration key

When you purchased Master Planner, you were given a Customer Number (which is a unique
number identifying you to Ross Software) and a Registration Key (which unlocks all the features of
the program). Version 4 registration keys have 12 letters (not numbers). If you have multiple keys,
check which is the latest by typing it into the Update registration key tab of the Network
Administrator's Utility Program (netadmin.exe).

Note that registration keys issued for version 3 of Master Planner will not work on version 4. You will
not be able to run the program from the server or access shared files without a registration key valid
for network use. If you try to do so, you will be prompted to enter a valid registration key.
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To enter your registration details into a user's machine, select Register Master Planner from the
Help menu, and type in your company, location, customer number and registration key, and click OK.
The company name and location will be stored, and displayed on the splash screen when Master
Planner starts. The customer number will be displayed on the About Master Planner screen,
accessed from the Help menu, for reference should you need to obtain technical support.

If you need to reinstall Master Planner, and you have lost your registration key, contact Ross
Software at customerservices@ross-software.co.uk or phone us on the number given on our
contact page here  for a new registration key.

See also:

Installing the standard version
Installing the network version: network options

5.1.3 The registration screen

Figure 7 : entering the registration key

5.1.4 Program upgrades

When you purchase Master Planner 4, you are entitled to receive all incremental upgrades to the
program (that is, where the version number begins with 4, eg 4.1, 4.2, etc). The program will be
upgraded regularly to add improvements or to fix bugs, and each new version will be posted on the
Ross Software website at www.ross-software.co.uk for free download. After downloading, follow
these steps:

· Copy the setup file (setup.exe or mp4setup.exe) to both the StandardSetup and AutoSetup
directories.

· Run the setup file from the StandardSetup directory, selecting Network options and then Install
to the network server.

· If all users have client installations (that is, run Master Planner from the server), nothing further
needs to be done.

· If some users have stand-alone installations (that is, they have the Master Planner program files
installed on their own machine), open the Network Administrator's Utility Program, and select the
Update program files page. Set the correct date of the update and click the Save button.
Whenever these users next access a planner file held on the server, they will be invited to update
their installation. Note that this will only be effective if you have previously entered information
about the program directory and planner file directories to the Network Administrator's Utility
Program. You can check which users have received the update by checking the mpk.log files in
the Master Planner program and planner files directories (on the Review update logs tab in the
Network Administrator's Utility Program).

Manual upgrades You can also upgrade stand-alone installations manually, if required. This may
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be necessary if problems arise with automated upgrades, or if you want to monitor the upgrade.
Simply run the setup program (setup.exe or mp4setup.exe) from the StandardSetup directory on
the server, or from the program disk. Select Stand-alone installation; for an upgrade to an existing
installation, there is no need to set up shortcuts or enter the registration key.

For an even quicker installation, run the setup program from the StandardSetup directory with the
command-line parameter /S which will silently run a stand-alone installation with default settings,
and will restart Master Planner afterwards.

5.1.5 Network version problems

The Network version of Master Planner is more complicated than the Standard version, since it
allows multiple users to share data and it has some additional functionality. Here are some of the
special problems you may encounter:

Problems with custom icons: the Network version allows you to create your own custom icons to
use on the planner (how? ). Once you add these icons to the planner toolbar, however, every
user must have access to the bitmap files for the custom icons. The bitmap files should be saved to
the same directory as the Master Planner program or the planner file itself or an Icons subdirectory.
This applies both to the server and any stand-alone installations accessing the planner away from
the office. If a custom icon bitmap cannot be found, the program will still run, but these icons will be
shown as a symbol on the planner toolbar or on the planner grid.

Problems accessing shared planner files: occasionally, a planner cannot be opened for editing
even when no other user is accessing the file. This usually occurs after a computer or network
crash, or possibly because a user's computer has hibernated. Open the Network Administrator's
Utility Program (netadmin.exe) and check the user files on the Monitor users tab to see if a user
is incorrectly registered as editing the file (the user file has the same name as the planner file but
with a .usr extension, and is in the same directory as the planner file). If so, ask that user to run
Master Planner and reopen the file, and then close down normally. If this is not possible, delete the
user file entirely and reset the read-only flag on the file (this can be done from the Monitor users
tab).

Problems with the amber traffic light: access to shared planner files on the server is controlled

by the traffic light icon. The amber light  indicates that the planner has been updated by another
user; click the button to refresh the planner to show the latest data. Occasionally the amber light
misbehaves; see Why is the amber traffic light not working properly  for more information.

Problems with upgrades: upgrading Master Planner can be complicated when there are many
users. It is recommended that you use the Network Administrator's Utility Program to keep track of
installations and allow automated updates (more ). If you have problems with automated
updates, you can still run manual upgrades (how? ). If you have a delayed roll-out of version 4,
and some users still have version 3, Master Planner 4 can export planner files in version 3 format.
You should use this feature with caution, however, as data may be lost.

5.2 The Network Administrator's Utility Program

5.2.1 The Network Administrator's Utility Program: an overview

The Master Planner Network Administrator's Utility Program allows you to carry out routine
maintenance tasks within one easy-to-use package. The program (netadmin.exe) and its data file
(netadmin.ini) are installed to the NetAdmin subdirectory of the Master Planner application
directory on the server. They can be copied to removable media (such as a memory stick) for
convenience. For added security, you may wish to remove them from the server altogether.

Note that you do not need to use the Network Administrator's Utility Program. If your company has
effective procedures in place for client installation and upgrades, you may prefer to continue to use
them.

Functions available on the network administrator's utility program include:
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· Set Master Planner directories: store the location of the application, the setup program, the
automated client setup files and any directories on the server containing planner data files.
(More )

· Automated client installation: specify settings to be used to run multiple client installations with
minimum intervention. (More )

· Update program files: trigger automated program updates for users with a stand-alone
installation. (More )

· Update registration key: change the registration key when you increase the number of licenced
Master Planner users, and trigger automated updates for users. (More )

· Review update logs: check which users have received updates to the program or registration
key. (More )

· Maintain an installations list: keep a list of which machines have client installations and which
have stand-alone installations. (More )

· Monitor Master Planner users live: check who is accessing the program and shared files, and
who is currently editing a file. (More )

See also:

Installing to a network
Client installation: options
Network version maintenance
Entering a registration key

5.2.2 Why use the Network Administrator's Utility Program?

You do not need to use the Network Administrator's Utility Program. If your company has effective
procedures in place for client installation and upgrades, you may prefer to continue to use them.

There are some special features which make management of large numbers of Master Planner
users much easier, however:

· Automated registration key changes: every installation of Master Planner, whether running
from the network (client) or locally (stand-alone) must have a valid registration key entered, to
unlock all the features of the network version. When you first purchase Master Planner, you will
be given a temporary (time-limited) key. When you pay, you will receive a new, permanent key.
Later, if you add additional users, you will be given another new key, valid for the new number of
users. Each new key must be entered onto each machine running Master Planner. With large
numbers of installations, this becomes a real chore. The Network Administrator's Utility Program
automates this process - enter the key once, and all users will be updated automatically
whenever they run Master Planner from the server, or access a shared planner file on the server.

· Automated upgrades: new versions of Master Planner are posted regularly on the website at
www.ross-software.co.uk to add functionality, fix bugs and other improvements. If you have
multiple stand-alone installations, it can be a real chore to update every machine manually. The
Network Administrator's Utility Program automates this process for users who regularly access
the program or shared files on the server.

· Monitor Master Planner users: the Network Administrator's Utility Program shows you, for every
planner file, which users are viewing it, who is currently editing and whether these users are
active or inactive. Inactive users are those whose computer crashed while Master Planner was
running, or is in hibernation. This is the only way to read the Master Planner user (.usr) files,
which are encrypted.

5.2.3 Setting Master Planner directories

On the Directories tab of the Network Administrator's Utility Program, you store a record of where
on your server the Master Planner program, setup file and planner data files are stored.

IMPORTANT This information is for your reference, but is also used elsewhere in the utility program
to facilitate maintenance tasks, such as triggering automated updates. The automated updates
will not work unless the directory data is correctly entered.
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You can store the following information:

· The server directory containing the Master Planner application (mastplan.exe), help files and
sample planner files.

· The server directory (usually StandardSetup) containing the Master Planner setup program
(either setup.exe or mpsetup.exe), which you downloaded from the Ross Software web site at
www.ross-software.co.uk or copied from the disk you were supplied with when you purchased
Master Planner.

· The server directory (usually AutoSetup) containing the files required for automated client
installation; these are the setup program, as above, together with a text file, client.txt, containing
the settings for a silent client installation. Click the Automated client installation tab and then
the Create or edit configuration file to create the text file (more ) or you can create or modify
it by hand (how? ). A sample text file is supplied as part of network installation.

· A list of server directories which contain planner data files; these usually have a .mpf extension.

5.2.4 Automated client installation

On the Automated client installation tab of the Network Administrator's Utility Program, you can
set up a configuration file to run client installations automatically, with minimum intervention. A client
installation sets up the client machine to run Master Planner from the network; it does not install
program files, but it can create shortcuts in the Start menu or on the desktop, both to the program
or to pre-existing planner files, and will store the registration key.

Select the Automated client installation tab, and click the Create or edit configuration file
button. A wizard will guide you through the process of setting up options (more ). Save the
configuration file (client.txt) to the MasterPlanner\AutoSetup directory on the server (or any
directory of your choice), and ensure that a copy of the Master Planner setup program (setup.exe
or mpsetup.exe) is in the same directory.

To run automated client installations, go to the client machine and run the setup program from the
AutoSetup directory (or whichever directory you have chosen). The setup will run without any input
from you, installing the options you have selected. Note that it may take some time to complete.

Note: whenever you run the setup program from the directory which contains the automated client
installation configuration file (client.txt), the setup program will run the automated client setup. To
run a manual setup, either use a copy of the setup program in a different directory, or temporarily
rename client.txt.

Note that you can create a client installation without using the setup program, if you prefer. Since no
special runtime files are required for Master Planner 4, all that is needed is a shortcut to the
program on the server. You can also create shortcuts which will open a particular planner file
(how? ). However, it is recommended that you use the setup program for convenience.

5.2.5 Automated client installation settings

On the Automated client installation tab of the Network Administrator's Utility Program, select the
Automated client installation tab, and click the Create or edit configuration file button. A wizard
will guide you through the process of setting up options.

1. First ensure that you have installed Master Planner to the server. If you have not yet done so,
exit the Network Administrator's Utility Program now and do so (how? ).

2. Set the location to save the configuration file (client.txt) - by default, this is
MasterPlanner\AutoSetup directory on the server, but you can change this. Also check that
the location of the Master Planner program files is correctly shown - if not, click Cancel and go
to the Directories tab to reset it.

3. Select shortcuts for program items to be added to the Start Menu and desktop during client
installation.

4. Select up to 10 existing Master Planner files - for each of these, you can add shortcuts to the
Start Menu or desktop, or set them to open in Master Planner automatically whenever
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Windows starts up. One file may also be set to be the default planner file, which will open when
Master Planner starts if no other planner file is specified.

5. Check that the registration key, customer number and company details are correct - if not, click
Cancel and go to the Update registration key tab to change them.

6. Check that the settings are correct, then click Finish to save the configuration file. Click the
Print button to print a summary of your chosen settings, and detailed instructions for running
automated client installations.

7. Finally, ensure that a copy of the Master Planner setup program (setup.exe or mpsetup.exe)
is in the same directory as the configuration file. You are now ready to run automated client
installations: simply go to the client machine and run the setup program from the AutoSetup
directory (or whichever directory you have chosen). The setup will run without any input from
you, installing the options you have selected. Note that it may take some time to complete.

5.2.6 Updating program files

On the Update program files tab of the Network Administrator's Utility Program, you store details
of any upgrades you have carried out to the network installation of Master Planner, and trigger
automatic upgrades to stand-alone installtions.

WARNING Before using this feature, you must ensure that the Directories tab has the correct
information; the automated updates will not work unless the directory data is correctly entered.

When you have upgraded Master Planner on the server (how? ), set the correct date and click
the Save button. Details of the new upgrade will be added to the list.

Note that the list shows all upgrades applied through the Network Administrator's Utility Program,
including changes to the registration key and company details (select the Update registration key
tab to change these).

5.2.7 Updating the registration key

On the Update registration key tab of the Network Administrator's Utility Program, you store
details of any changes to the Master Planner registration key or your company details, and trigger
automatic updates to user machines.

WARNING Before using this feature, you must ensure that the Directories tab has the correct
information; the automated updates will not work unless the directory data is correctly entered.

Enter the new registration key; you can see at once whether the key is valid, how many users it
allows and whether it has an expiry date or not. This is useful if you have been given several
registration keys, and you are not sure which is the correct one. Click Restart to revert to the
original data.

You can also enter or change your company's name and location, and customer number. The name
and location are displayed on the Master Planner splash screen to remind users that the software is
licenced to your company. The customer number allows Ross Software to identify you as a
registered user if you need technical support.

When you have make any required changes, click the Save changes button. You can see a list of
all automated changes on the Update program files tab.

5.2.8 Reviewing update logs

On the Review update logs tab of the Network Administrator's Utility Program, you can view all
updates carried out automatically on user machines.

When you initiate an automated update of the Master Planner program, registration key or company
data, the details are stored in a text file (mastplan.mpk). A copy of this file is then added to the
Master Planner program directory and to every directory holding planner data files. The directory
information is taken from the Directories tab.
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Whenever a user runs Master Planner from the server, or accesses a shared planner file on the
server, the program will look for the mastplan.mpk file, and apply any updates outstanding for that
user. A record of each update will then be stored in a log file (mastplan.mpk.log). These log files
can be viewed on this tab.

The upper box shows any update log files already found; you can browse for any others not shown.
Click the name of the log file to show all the updates. You can select multiple log files at once, to
view all updates; hold down the Ctrl key while selecting a file to add it to the selections, or click and
drag to select adjacent items on the list.

The lower box shows all updates carried out, giving the date, computer name and the name of the
user logged on. Updates are shown with the most recent at the top. When multiple log files are
selected, the data is merged in date order. You can print the details for reference.

5.2.9 Installations list

On the Installations list tab of the Network Administrator's Utility Program, you can enter details of
Master Planner installations at your company. You may want to record which users have a stand-
alone installion, for instance, and which have a client installation. This data is for your information
only, and is not used elsewhere in the Network Administrator's Utility Program.

You can also enter any other information you wish, for example, notes about upgrades or any
problems you may have encountered, or reminders about tasks to do.

When you have finished, click the Save changes button.

5.2.10 Monitoring Master Planner users

On the Monitor users tab of the Network Administrator's Utility Program, you can view live data
showing which users are using the Master Planner program on the server, and which are viewing or
editing shared Master Planner files.

Each planner data file on the server (which usually has a .mpf extension) has an associated user file,
which tracks all active users viewing or editing that file. The user file has the same file name as the
planner file, but with an additional .usr extension. For example, the user file for M:\OfficePlanner.mpf
would be M:\OfficePlanner.mpf.usr. The Master Planner program also has a user file
(mastplan.exe.usr). All users must have full read-write access to the user files.

Active users update the user file every 5 minutes; inactive users have not updated the user file for 10
minutes or more, typically because of a crash or hibernation. The upper box shows user files in
directories listed on the Directories tab; the lower box shows user status.

Normally, inactive users are automatically removed after 24 hours. However, if an inactive user is
flagged as editing a file, they will not be removed in order to protect the integrity of the planner data.
This means that no other users can edit that planner. In such cases, you should ask the inactive user
to reboot or end hibernation, reopen the planner file and close it for editing.

If this strategy is not possible, you should delete the user file altogether and reset the read-only flag
on the planner file (click the Delete button to have the program do this for you). Active users will then
automatically recreate the user file.

WARNING Deleting a user file should only be done as a last resort, since it could result in two users
being flagged as editing the same file. This could result in loss of data.



Master Planner 4 - Network Administrator's Guide 27

© 2005 ... Ross Software

6 Troubleshooting

6.1 Problems

6.1.1 Getting answers to problems

If a user is having trouble with a particular screen, press F1 for help with that screen. Most screens
also have a Help button, and on the planner screen the Help menu gives a range of options. The full
manual (downloadable from the website) contains all the information in the help file, plus screenshots
of all parts of the program.

Common problems:

The toolbars have disappeared! (Docking toolbars sometimes misbehave; select Toolbars on the
menu and click Reset to default positions; see the help file or manual for more information)
It's impossible to remove some icons from the planner (More )
Some of the buttons are disabled (greyed out) (More )
What is this  symbol on the toolbar or planner? (More )
Master Planner is slow to open (More )
Only some of the names on the planner appear (More )
QuickPrint doesn't print as expected (More )
Master Planner thinks it is the unregistered version (More )
What does the * mean on an icon's tooltip? (More )
Why is the amber traffic light not working properly? (More )
Page breaks on planner reports are incorrect (More )
Network version problems (More )

Still having trouble?

Contact Ross Software for technical support (how? ), giving us as much information as you can
about the version of Master Planner you are using (click About Master Planner on the Help menu),
the planner you are using (how many names, the start and finish date, etc) and any error message
you are getting.

6.1.2 Slow loading

Like all graphical programs, Master Planner likes a fast machine - at least 200MHz is recommended.
To improve loading speed, try the following:

· Remove out-of-date weeks from the planner.
· Remove unnecessary time periods from the planner.
· Split the employee list into two or more planners.
· Upgrade to a faster machine.

6.1.3 QuickPrint report not as expected

QuickPrint prints a selected memorised report immediately, using the selections and print settings
specified in the report. The default QuickPrint report is the first memorised report, an instant planner
print of all names on the current view taken from the currently visible section of the planner. The
appearance of this report (font, lines per page and so on) may be changed, but selection criteria may
not. If your selected QuickPrint report has been deleted, this report will be used instead.

Users of previous versions of Master Planner may have inherited an earlier QuickPrint report, saved
as the second memorised report (called 'Selected planner print'), which may be changed or deleted.
QuickPrint options are personal to each user.

To review settings for your QuickPrint report, click Print on the File menu, select the QuickPrint
report option and then click the Edit button. You will be able to change the selection criteria and print
options for this report; click the Memorise button to save your changes.
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To set a different report as your QuickPrint report, or to switch QuickPrint on or off, select Print on
the File menu, and click the Defaults button.

See also:

Page breaks on planner reports are incorrect

6.1.4 Missing symbols on the grid or toolbar

If the  symbol appears on the toolbar or grid, this means that Master Planner cannot identify the
correct symbol to use. This may happen for one of these reasons:

· The external toolbar file for this planner cannot be found. The program will use the default set of
icons and the planner data will not be lost. If you can find the missing file, or restore it from backup,
you can reattach it to the planner by selecting the Edit toolbar icons option from the Edit menu
and clicking the Import toolbar button. If the toolbar file cannot be found, you will need to recreate
it by editing the default toolbar.

· The bitmap for a custom icon cannot be found. When custom icons are addedto a planner toolbar,
the bitmaps must remain in their original location. If the bitmaps have been moved, move them to
the same location as the toolbar file (or the same location as either the planner file or the program
itself, or a subdirectory of any of these named [Icons]).  The planner should now be correct.

6.1.5 Unregistered when should be registered version

The version of Master Planner installed is the same regardless of whether you are running the
unregistered (demo), Standard or Network version. The features of the registered version are
unlocked by means of a registration key.

You were given a registration key when you first purchased Master Planner. Select Register Master
Planner from the Help menu and type in your company name, location, registration number and
registration key and click OK. Master Planner is now fully operational and ready for use.

If you have installed Master Planner onto a different machine, the registration process must be
repeated for the new machine.

If you have previously successfully registered Master Planner, but it now thinks it is unregistered, you
may have inadvertantly deleted a setting in the registry. In this case you should re-enter the
registration key.

Contact Ross Software (how? ) for technical support if you are unable to resolve this problem.

6.1.6 Not all resources are showing

You may be seeing only part of the planner because you are currently in a planner view. Press the F5
key to restore the full planner. Note that data is never lost when you see only part of the planner; a
view is just a way of making a large planner easier to manage.

If only some names are showing when Master Planner first opens, this is because one or more
personal views may have been created, and one specified as the default view. Use the F6 key to
move from one personal view to the next, or select Full planner from the Views menu, or from the
drop-down list on the views/search toolbar. To change the default personal view, select Edit
personal views from the Views menu.

6.1.7 Illegal icons

Occasionally, an icon may appear on the planner marked with an asterisk (*) in the tooltip shown
over the cell and in the status bar (if the tooltip does not appear, click a cell to select it). This means
that the icon is being tracked (its use on the planner is restricted), and this occurrence of it is illegal.

See the help file or manual for further information about icon tracking.
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6.1.8 Why is the amber traffic light not working properly?

The management of network (shared) files is controlled by the traffic light icon on the main toolbar.

Normally the light shows red  to indicate that the file is read-only or green  to indicate that the
file is open for editing. However, if another user updates the file (that is, makes some changes and

saves the file), a red traffic light will turn amber  to indicate that the file needs to be refreshed;
click the traffic light to refresh the planner and view the changed data. The amber light will be
shown for all users viewing (not updating) the planner file. If the planner is minimised to the taskbar
or system tray, the program icon will always display the current traffic light status.

Occasionally, the amber light can behave erratically, either not changing from red to amber even
though the planner file has been updated, or repeatedly changing to amber after the planner has
been refreshed. In these cases, check the system date and time both on your computer and on the
server where the planner file is held. The amber light depends on all client machines setting their
clocks to the server time; if there is a difference the amber light mechanism will not work correctly.
If a user encounters this problem, you should ensure the clock is set correctly.

6.1.9 Page breaks on planner reports are incorrect

In previous versions of Master Planner, categories were restricted to 'Department' and 'Employee
type', and these were the only page breaks available on a planner report. A default page break
setting was stored with the personal settings, so that a newly created planner report would open
with the preferred page breaks already selected, and the instant planner report would also use
these settings. If these categories are retained in a version 4 planner, the default page breaks will
continue to be used for backwards compatibility.

To change this, open the default planner report, which is called 'Instant planner print' by clicking
Print on the File menu, selecting the report from the drop-down list and clicking Edit. Set your
preferred default page breaks (using 'Department', 'Employee type', both or neither) on the
Settings tab. Click Memorise to change the settings just on this report; check the Set these
options as the default for all reports option on the Options tab and print the report to change the
default page breaks saved with your personal settings.

6.1.10 It's impossible to remove some icons from the planner

Icons (symbols) added to the planner can be removed by selecting the cell or an area of the planner
with the mouse, and pressing the Delete key. However, some icons cannot be removed in this way;
no matter what you do, they are still there! There are three possible reasons why this may happen:

· The icons apply to a whole column: an icon can be defined such that, when it is added to the
planner, it will fill all the selected columns, not just the actual cells highlighted. In the default set of
built-in icons, the bank holiday symbol is the only column-wide icon, but others can be added, for
example, for a company holiday. No other icons can overwrite a column-wide icon, and they
cannot be deleted in the usual way; instead, use the Clear column function from the Edit menu.
To change the icon so that it no longer applies to columns, select Edit planner icons list from
the Edit menu, select the icon from the New symbols toolbar chart, and uncheck the Column
check-box. The icon can now be deleted from the planner in the usual way.

· The resource is not available for activities (rows are greyed out): if the resource start and/or
finish dates have been set, days when the resource is not available for activities will be shown
greyed out on the planner; it is impossible to clear these cells or overwrite them with activity icons
(although notes can be added). To check or change the resource start and finish dates, double-
click the resource in the list.

· The planner is a calendar-year or fixed date style (columns are greyed out at the start and
end of the planner): in this case, the few days immediately outside the planner date range are
greyed out, to make it easy to see the exact start and end days; these cells cannot be cleared or
overwritten with activity icons (although notes can be added). To check or change the planner
date range, select File settings from the Options menu and click the Style tab.
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6.2 Support

6.2.1 Contacting Ross Software

Technical support:

Support will be available to registered users, preferably via e-mail. If possible, please quote your
customer number on all correspondence. Send all comments, suggestions, enquiries and problem
reports to pmross@ross-software.co.uk.

For problems, please give as much detail as possible, for example, size and type of machine,
operating system, any error messages encountered and size of planner. For unexpected errors, a
window will appear describing the error; please click the button to email the bug report to Ross
Software - these reports are very helpful, and usually enable us to track down and fix the problem
straight away.

Contact details:

Email:
customerservices@ross-software.co.uk

Mail:
Write to Ross Software, 18 Sutors Gate, Nairn, Scotland IV12 5BW, UK.

Phone:
+44 (0)1667 453537

Fax:
+44 (0)1667 454531

Website:
For the latest information about Master Planner, including regular upgrades, check the Ross
Software website at www.ross-software.co.uk


