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Section 1: Getting started 
Overview 

Master Planner is a graphical version of a wall planner, presented as a grid, with names of employees down the 
left and dates across the top. A planner may show a number of weeks, or a whole year, or you can specify exact 
dates. Add icons to grid squares to indicate the activities of employees on selected dates - holidays, project 
work, conferences and so on. 

 

 

Figure 1: planner showing the symbols and editing toolbars 

Each employee has from 2 to 12 lines for icons on the planner, for activities during different time periods. For 
each employee, you can specify their department, employee type and start, finish and birthdates. A wide range 
of icons is available, from which you can choose just the ones appropriate to your company. A text note may be 
added to any grid square to record additional information. 

Floating toolbars give access to editing functions and moving around the planner may be achieved using mouse 
or keyboard operations. An undo function is available. A status bar, tooltips and full on-line help make Master 
Planner easy to use. 

For larger planners, you can view a single department or employee type, while the statistics function shows the 
number of times an icon has been used for a time period. Planner information may be printed as shown on 
screen, as individual schedules or showing text notes, and full backup and restore functions are available. 

New for version 3.2 

New file format 

Version 3 and interim upgrades of Master Planner have a number of extra features. Because of these additional 
features, the format of planner files has changed slightly. All files of the older format will continue to be 
accessible, but they will be saved in the new format which cannot be read by earlier versions of Master Planner. 

Weekly schedule report 

This new report will print both icons and any text notes for selected employees for one or more weeks. Select 
employees individually, by department or by employee type. Select Print from the File menu to create this 
report. 
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Resizable columns 

The employee name column (or the department and initials columns) can be resized using the + and – buttons. 

Extra date column headings 

The date column headings can now show the week number instead of the week start date, and a new row of 
headings shows the day or first letter of the day above each day on the planner. Select Preferences from the 
Options menu, and select the Dates tab to set these options. 

Preferences dialog 

A new dialog collects all user-specified settings into one place, and adds many new choices. Date headings, 
colours, startup options, recent files and global settings are all accessed by selecting Preferences from the 
Options menu. The new settings include: extra date column headings; colour choice for grid selection highlight; 
recent file list deletion; show program in system tray; and warn when overwriting icons. 

Extra employee contact details fields 

Two new fields on the employee details screen allow a contact phone number and email address to be stored. 
Double-click a name to change details. 

Switch off date reminders 

When a planner is opened, a popup window reminds of any birthdays, or employees starting or leaving that day. 
This feature may now be turned off. Select File details from the Options menu (network files must be open for 
editing). 

New for version 3.1 

More daily time periods 

Now you can have up to 12 daily time periods per person on your planner. This allows finer planning detail, so 
you can allocate activities on an hourly basis. Of course, each daily time period can represent any amount of 
time you choose.  

Memorised reports 

You can now memorise any report of any type - planner printout, notes, personal schedules or statistics. All the 
selection details for that report - names, departments or employee types, dates, font settings and report options 
- can be saved with the planner file and easily printed by any Master Planner user with a few mouse-clicks from 
the menu. You can also specify which view to use for future printing, and whether to use the original or default 
print settings.  And a user can set any memorised report to be their QuickPrint report, to be printed with a single 
click from the toolbar. 

In addition, the last report you printed will be saved while Master Planner is open, and can be reprinted instantly 
from the File menu or opened for modification in the print wizard. 

New for version 3 

More flexible date ranges 

Now you can specify exact dates to start and end your planner. When you create a new planner, you can 
choose an exact number of weeks, a calendar year (1st January to 31st December, including past or future 
years) or enter your own dates to fit in with your company’s activities (financial year, tax year, academic year, 
etc.). You can apply this feature to an existing planner or change your choice later, although data may be lost: 
select Date Range from the Options menu. 
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Customisable icons 

Now you can choose from a much wider range of planner toolbar icons, and set your own descriptions. In 
addition, any planner icon can now be set to apply to an entire column (for example, a bank holiday which 
applies to all staff). Select the Edit toolbar icons option from the Edit menu to make changes. You can apply 
your choices just to the current planner, or save the icon set to be available for other planners. Standard version 
users can only save one icon set, but Network version users can save multiple toolbar files, and create custom 
icons. 

More employee types 

Now there is no limit to the number of employee types you can define. Add new employee types as you need 
them when adding or changing employee details. Employee types and departments are used to specify planner 
views, to compile statistics or in printing reports. 

Planner views 

Now you can choose how you view your planner - all of it, or just a single department or employee type (select 
the view you want from the Views section of the menu). Use the F5 key to return to the full planner view at any 
time.  

To create a personal planner view, select Edit personal views from the Views menu. In the views dialog, 
select the departments and/or employee types you want to include and give your view a name. You can create 
any number of personal views. Details of your personal views are stored on your INI file and so are available 

only to you. Use the new  button on the toolbar (or use the F6 key) to switch between the full planner and 
your personal planner views.  

You can make changes to icons and notes on the planner from within a view, but you must switch back to the 
full planner to make planner-wide changes, such as adding, deleting or moving employees or changing the date 
range, number of daily time periods or days in a planner week. 

Icon usage statistics 

It is now possible to see the usage for any icon for an individual, or by department or employee type. Select 
Statistics from the menu, then select the required icon, the people/departments/employee types required, the 
date range and any options. You will be shown a breakdown of the usage for that icon. Use the blank icon 
button to show availability (that is, no icons on the planner). The statistics can be printed, if required. 

Cut, copy and paste 

Now you can cut, copy and paste icons, or blocks of icons, or notes, or both, using keyboard shortcuts. First 
select the cell, or block of cells, to be cut or copied and use one of the following keyboard shortcuts: 

 Ctrl-X   to cut icons 
 Ctrl-C   to copy icons 
 Shift-X  to cut notes 
 Shift-C  to copy notes 
 Ctrl-Shift-X to cut icons and notes 
 Ctrl-Shift-C to copy icons and notes 

Then select the top left cell of the area to be pasted to, and type  

 Ctrl-V  to paste icons 
 Shift-V  to paste notes 
 Ctrl-Shift-V to paste icons and notes 

If you make a mistake while cutting or pasting icons, you can undo in the usual way. There is no undo facility for 
notes moved using cut, copy and paste. You can, of course, repeat the paste action as many times as you want. 
These functions are also available from the Edit menu. Note: icons applicable to an entire column (such as 
bank holidays) and non-availability cannot be edited in this way. 
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Choice of colours 

In order to make it easier to distinguish between different employees when adding icons to the planner, there is 
now an option to show horizontal colour banding, which highlights the grid cells applying to alternate employees 
in colour.  

Vertical colour banding is also available, showing either alternate weeks (for 5 day planners) or weekends (for 7 
day planners) in colour.  

To change the horizontal or vertical banding, or the colours used, select Options from the menu, then Colours, 
and choose your preferred colours. You can also change the colour of the names and dates areas on the 
planner. Your choice will apply to all planners you view. 

Print a planner for any date 

Now you can print any part of the planner. Select Print from the File menu to open the print wizard, and select 
the Print the planner option. You will then be able to select either individual employees or specific departments 
and/or employee types, and a starting date to print from, as well as a range of print options to format the report 
to your preference. Your selections can be stored to enable an instant printout to be made from the toolbar. 

Print notes by date 

Now you can print out only the notes applicable to a certain date range. Choose the Print selected notes option 
on the File menu and select from a range of date options. You can also print notes for a wider range of dates by 
selecting Print from the File menu to open the print wizard. Select the Print notes option and specify the exact 
dates required, plus a range of print options to format the report to your preference. 

Print personal schedules 

Now you can print a personal schedule for any employee, showing both icons and notes together. Open the 
print dialog by selecting Print from the File menu, and select the Print personal schedules option. You can 
select individual employees or entire departments and/or employee types, and the dates to be printed, and set 
printer options. Each employee’s schedule prints on a new page. You can also obtain an instant schedule for 
the current week or next week, using default settings, by selecting an employee on the planner list and selecting 
Print schedule for… on the File menu. 

Automatically run when Windows starts 

Once you have specified a save location for your planner, you can run that planner automatically whenever 
Windows starts up. Select File details from the Options menu, and click Next until you see this option. You 
can choose to have your planner open normal size, minimised to the task bar or minimised to the system tray. 

Note: Master Planner is a graphical program making heavy use of system resources. If you try to run several 
planners simultaneously, you may run out of system resources, especially if other applications are running. 

Installing Master Planner 

Technical specifications 

Master Planner is 32-bit software, so it only runs under Windows 95/98/2000 and NT 3.51 and above. It will not 
run under Windows 3.x or Macintosh. Installation is by self-installing executable. You will need approximately 6 
Mb of free hard disk space. A minimum of 32 Mb of RAM (memory) is recommended. As with all graphical 
programs, a faster machine improves performance - 200MHz or better is recommended. 

Master Planner can be connected to almost any inkjet or laser printer. Full colour printing can be obtained when 
connected to a colour printer, or reports may be printed in text-based black-and-white style if required.  

A planner may be any size from 4 to 150 weeks (almost 3 years), with no theoretical limit on the number of 
employees. With the periodic removal of out-of-date weeks, it may be used indefinitely. Master Planner is fully 
year 2000 compliant. 
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Obtaining Master Planner 

Registered users of the program may request the program on disk to facilitate installation to a new machine. 
You can also download the latest version of Master Planner from the Ross Software web site at 
www.ross-software.co.uk. Once you have downloaded the file and saved it, find the file in Windows Explorer 
and double-click it to begin the installation process. 

Upgrading from earlier versions 

You can install Master Planner 3 to the same location as an existing installation if you wish, or you may choose 
to install separately. The program will read planners created in earlier version, but note that each version saves 
in a different format which cannot be read by earlier versions of the program. As with any software, it is 
recommended that you back up all planner, toolbar and custom icon files before installing a new version. 

Note that all versions use the same configuration (INI) file, and therefore open the same default file. If you wish 
to run a new version in parallel with an older version for testing purposes, you will need to take copies of all 
earlier version planners, and open these using a command-line shortcut, which bypasses the default file. See 
the Planner files section below. 

Installing the standard version 

To install Master Planner onto a desktop or laptop computer, start the installation program, and, when 
prompted, select the Stand-alone installation option. Shortcuts will be added to your Start menu to access the 
program, help file and sample files. There is also an uninstall program. 

This will install an unregistered (evaluation) version of Master Planner, which has some features disabled. To 
unlock all the features, you will need to use the Registration Key which was given to you when you purchased 
Master Planner. Select Register Master Planner from the Help menu, and type in your company, location, 
customer number and registration key, and click OK. Master Planner is now ready for use (some versions of 
Windows require administrator rights for installation). 

Installing the network version 

The network version of Master Planner may be installed to the server if required, so that the program is easily 
available to all users with network access (see the section Installing to a network server, below). 

Each user should then run the Master Planner client installation; this will ensure that common Microsoft system 
files are correctly installed and registered. In addition, the client installation allows a range of shortcuts to be 
added to the client machine, allows Master Planner to open with a specific planner file when Windows runs 
(minimised to the task bar or system tray, if required) and allows the registration key to be updated 
automatically. Client installation may be automated (see the sections Installing to a network client and 
Automated client installation, below). 

If preferred, individual users of the network version may install the stand-alone version instead of the client 
installation. This will install and register all components on the client machine, and allows the program to be run 
away from the network (see Installing the standard version, above). 

Either installation method allows full access to all planner files, regardless of whether they are held on the server 
or the local machine. Local files will normally be fully editable; files on the server will be multi-user - that is, only 
one user may edit the file at a time, but any number of users may view the file (see Accessing network files in 
the How to use Master Planner section, below). Use your usual network software to control who has read-write 
access, and who has read-only access. 

Installing to a network server 

Only the Network version of Master Planner may be run from or access files on the network server.  To install 
Master Planner onto the network, start the installation program, and, when prompted, select the Network 
option, then select the Installing to a network server option. This will install all the Master Planner program 
files to the server. You may also set up the installing machine as a client machine at the same time, if required.  

When you have installed the program files to the server, you may set up additional client machines (see 
Installing to a network client, below), or you can install the full program to client machines (see Stand-alone 
installation, above) if you may need to run Master Planner when not on the network. 
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Note that a server installation only installs the program files, not the run-time (system) files, and no shortcuts are 
added to the start menu. 

Installing to a network client 

To install a client version of Master Planner, start the installation program, and, when prompted, select the 
Network option, then the option to Setup client to run program from server. You should have previously 
installed the program to the server or you can do this at the same time. 

Client installations may choose whether to create desktop or start menu shortcuts, select an existing planner file 
to be run automatically when Windows starts and enter a registration key. It is also possible to automate the 
client installation process; see the section Automated client installation below for full details on this. 

Warning: if you fail to enter a valid registration key, or you have purchased only the Standard (single user) 
version of Master Planner, you will not be able to run the program from or access planner files on the network 
server. 

Automated client installation 

The setup program can be run automatically for client installations to speed the process of installing to several 
machines. To do this, you should first install the program to the network server (see above). 

You must then create (using Notepad or a similar text editor) a file “client.txt” which will list your required client 
installation options. A sample is installed with Master Planner. The file looks similar to this: 

InstallAutomatically=Y 
ApplicationDirectory=n:\program files\master planner 
StartMenuOptions=ABCE 
DesktopOptions=AB 
AutoRunOptions=D 
PlannerFile=n:\files\planner.mpf 
RegistrationKey= 

Valid values are as follows (do not use quotes round file paths): 

InstallAutomatically: must be Y 

ApplicationDirectory: path of the program file (mastplan.exe) without ‘\mastplan.exe’, eg 
ApplicationDirectory=N:\Some Directory\Master Planner 

StartMenuOptions: either X (no shortcuts will be added to the Start menu) or any combination of A 
(program), B (help file), C (sample files), D (uninstall program), E (shortcut to an existing planner file) 

DesktopOptions: either X (no shortcuts will be added to the desktop) or any combination of A (program), B 
(shortcut to an existing planner file) 

AutoRunOptions: sets an existing planner file to run automatically when Windows opens, valid entries are 
ONE of X (no AutoRun), A (no AutoRun), B (AutoRun normal size), C (AutoRun minimised to the 
taskbar), D (AutoRun minimised to the system tray). 

PlannerFile: the full path of the existing planner file for which shortcuts or AutoRun is required eg 
PlannerFile=N:\Some Directory\Master Planner\My Planner.mpf 

RegistrationKey: the registration key you were given (without spaces) when you purchased Master Planner 
or blank if already registered or unknown (you will not be able to run Master Planner from the network 
without a valid registration key). 

Save the “client.txt” file to the same location on the network as the setup program. When you run the setup, it 
will detect the client file and run a client installation without prompting for any information. To run a normal 
installation, either use the program disk directly, or copy the setup program to a different location, or temporarily 
rename the “client.txt” file. 
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Entering a registration key 

When you purchased Master Planner, you were given a Customer Number (which is a unique number 
identifying you to us) and a Registration Key (which unlocks all the features of the program).  

To enter your registration details, select Register Master Planner from the Help menu, and type in your 
company, location, customer number and registration key, and click OK (see figure 2). Master Planner is now 
ready for use. Note that some versions of Windows require administrator rights to enter a registration key. 

The company and location details will display on the Master Planner splash screen, and are also shown on the 
Master Planner About box (accessed from the Help menu). The Customer Number is also displayed on the 
About box; if you need technical support in the future, please quote this number if possible as it helps us identify 
you even if your company name and other contact details change. 

 

Figure 2: the registration screen 

If you need to reinstall Master Planner to a different computer, and you have lost your registration key, contact 
Ross Software at pmross@ross-software.co.uk or phone +44 (0)1252 795169 for a new registration key. 

The welcome screen 

After you first install Master Planner, you will see the welcome screen (see figure 3). 

This screen allows you to create a new, blank planner, ready for you to add the names of your employees; or to 
open one of the sample files provided, so that you can experiment with the program; or open an existing 
planner.  

Once you create and save your own planner, or specify an existing planner as the default (to open automatically 
when Master Planner starts) you will not see this screen again. 

Creating a new planner 

After installation, you may want to start by creating your own planner. Select this option and a wizard will help 
you create an empty planner, using the dates and names that you specify. You be asked if you want to add 
some names: select the Add some now option and click OK. You will also be able to add more names later: 

click the  button on the main toolbar and when the edit toolbar opens, click the  button. 

Viewing a sample planner 

Select this option, and one of the sample planners will be opened for you, and you will have the opportunity to 
experiment before you try creating your own planner. You can change, print from and save the sample planners 
as much as you want. You can also open a sample planner file by selecting Help on the menu bar from the 
planner screen, then clicking one of the Sample planner options, or by opening the file in the usual way, by 
selecting Open from the File menu. If you make changes to the sample files and want to restore the original 
version, rerun the Master Planner install program. 
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Figure 3: the welcome screen 

 

Browsing for an existing planner 

If you select this option, the standard Windows browse dialog will open, allowing you to search your local drives 
or network server (Network version only) for previously saved Master Planner files. These usually have a .mpf 
extension. 

Creating your first planner - a quick guide 

To start a new planner, select the Start a new planner option on the Wecome screen, or select File then New 

on the menu bar, or click the  button on the main toolbar. A wizard will guide you through the process of 
creating a new planner. You will be able to make changes later. Here is a brief summary; see the section 
Creating a new planner below for full details of all options. 

Planner name and save location: select one or two names to describe your planner. You may also specify 
where the planner is to be saved (optional). 

Planner size and format: select from three planner styles: 

 Standard - specify the number of weeks (from 4 to 150), starting from the current week 
 Calendar year - 1st January to 31st December only for your chosen year. 
 Fixed date - use the pop-up calendar to specify exact start and finish dates. 

You can also choose whether to have 5 or 7 days per week on your planner, and the number of daily time 
periods. 

Toolbar icons to use: a new planner will normally be created with a default set of toolbar icons (you can 
customise the toolbar later). If you have used Master Planner before, you can copy a toolbar from an existing 
planner, or a saved toolbar. 
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Copy names option: if you have used Master Planner before, you can copy a list of employee names from an 
existing planner to the new planner. 

Title bar/columns in employee list/show messages on opening: choose what to display on the title bar 
when Master Planner runs, which columns to show in the employee list and whether to display date reminders 
when the planner is opened. 

Click Finish to create your planner. If you did not copy any names, the planner will be empty and you will be 
asked if you want to add some names (you will not be able to add icons to an empty planner). Add a name or 
two, leaving all other fields blank for now - you will be able to delete or modify these later. 

Now open the planner symbols toolbar by clicking the  button on the main toolbar. Select an area of the 
planner by holding down the left mouse button and dragging the mouse until an area is highlighted. Now click 
one of the coloured buttons on the symbols toolbar - the selected area on the planner is filled in with icons.  

Click one of these icons on the planner, and the status bar and tooltip show the date, type of symbol and the 
person it applies to. Double-click any planner cell, type a note into the pop-up box and click OK. Now when you 
click an icon or hover the mouse over it, the tooltip shows the note you typed as well.  

Using Master Planner is as simple as that - remember to save your planner before closing the program, if you 
want to keep this data. Press F1 at any time for help. You can choose which planner icons you want to include 
on your toolbar; it is a good idea to make any changes now, before adding too many icons to the planner - 
select Edit toolbar icons from the Edit menu. 
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Section 2: How to use Master Planner 
The planner screen 

 

Figure 4: network planner open for editing, showing the symbols and editing toolbars 

Main toolbar 

This contains buttons for the main planner functions: exit, file operations, printing, backup, views, options and 
movement around the planner. It also has buttons to show the other two toolbars.  

Occasionally,some buttons will be disabled meaning that some editing functions are not available; this is 
normal when viewing a network file, and also occurs when a planner has no names on it, when viewing only a 
part of a planner, when the planner is already open in another instance of the program or when a temporary 
registration key has expired. When the situation has been corrected, all functions will be restored. 

In the network version, when accessing a file stored on the network server, a traffic light button controls 
access to editing facilites. Buttons controlling editing functions will normally be disabled for network files; click 
the traffic light icon to open the file for editing and click again to close it. 

 Exit program 

 Start a new planner 

 Open an existing planner 

 Save this planner  

 Select backup options and backup or 

 Backup to floppy disk now or 

 Backup to local/network hard drive now  

 Select report options and print or 

 Print selected QuickPrint report now using current settings 

 Move to the first week of the planner 

 Move to the top of the planner 
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 Move to the home position 

 Move to the bottom of the planner 

 Move to the last week of the planner 

 Show personal views 

 Open the planner editing toolbar  

 Open the names editing toolbar  

 Shows the current planner view 

Buttons applicable to files on the network server only: 

 Planner cannot be edited, click to request authority to edit. 

 Planner has changed, click to refresh. 

 Planner is open for editing; click when you have finished editing to make planner available to other users 
for editing. 

Planner toolbar 

This contains buttons for all the planner symbols (icons) and floats above the planner. Open it by clicking the 

 button on the main toolbar. You can move it to a convenient position, or close it when you have finished 
with it. To add or remove icons, or change descriptions, click Edit toolbar icons from the Edit menu. 

Add icons to the planner by selecting one or more planner cells and clicking the required icon on the toolbar. 
Buttons to clear cells and to undo the last addition are also provided. 

The toolbar can be specific to an individual planner, or can be saved to file to be used with other planners. 
Standard version users may only save one toolbar file, but Network version users may save any number of 
toolbar files and may also create custom icons for use on any Master Planner toolbar. 

If you see a  button on the toolbar, this indicates that an icon required for this toolbar could not be found. 

Edit toolbar 

This contains buttons to edit the employee names list (add, change, delete or move names), plus a button to 

edit the icons, and floats above the planner. Open it by clicking the  button on the main toolbar. You can 
move it to a convenient position, or close it when you have finished with it. Some editing functions are 
disabled when you are in a planner view; click F5 to return to the full planner view. 

Click to select a name before editing. 

 Add a name or line  

 Delete a name or line  

 Change name details 

 Move name or line up or down  

 Edit toolbar icons 

Titlebar 

The title bar shows the currently selected title, as well as the usual Windows furniture. The title always 
displays the words “Master Planner”, plus your choice of 4 possible options: the current planner year, the first 
planner name, the second planner name or the path of the currently open file. You can also choose to leave 
this part blank. 

To change your selection, select Options then File details from the menu bar. This information is stored in 
the planner file, so you can have different settings for each planner, if required. Network files must be opened 
for editing before changing this setting. 



How to use Master Planner 

 Page 12

File menu 

New: starts a new planner (you will be given the chance to save any unsaved changes to the existing planner 
first). 

Open: shows a dialog box to enable selection of a planner file to be opened (you will be given the chance to 
save any unsaved changes to the existing planner first). 

Save: saves the current planner. 

Save As: saves the current planner in a different location. 

Backup: shows a dialog window to allow the current planner to be backed up. 

Restore: shows a dialog window to allow an old version of the file to be restored. The current planner will not 
be overwritten until the restored version is saved (manually or by the AutoSave function). If you want to check 
the restored file before saving, be sure to switch AutoSave off first. 

Read notes: reads all notes for this planner sequentially (that is, in date order). Any note may be changed or 
deleted. 

Print notes: prints all notes for the current planner immediately using the current print settings (select the 
Print option to check or change print settings). 

Print selected notes: prints notes for the selected date range using current settings. 

Print: opens the print dialog box to allow printing. A variety of printing options and report types is available. 
Memorised reports may be created, modified, printed or deleted from the print wizard, and default print 
settings specified. 

Print symbols key: prints a full list of all the icons available for this planner (whether in use or not) 
immediately using the current print settings (select the Print option to check or change print settings). 

Print schedule for…: prints an immediate schedule, showing icons and notes, for the named employee, 
using current print settings. 

Print memorised reports: instantly print any previously saved report (select the Print option to modify or 
check the report). 

Reprint last report printed: reprints exactly as before (select the Print option to modify, check or memorise 
the report). 

List of recent files: opens the selected file immediately (you will be given a chance to save any unsaved 
changes to the current planner first). 

Exit: exits the program (you will be given a chance to save any unsaved changes to the current planner first). 

Edit menu 

Some editing functions are disabled when you are in a planner view; click F5 to return to the full planner view. 

Add name: shows a dialog window to enter details about the employee to be added. The new line will be 
added after the currently selected line (highlighted in red letters). Change the selection by clicking or use the 
keyboard shortcuts. 

Delete name: deletes the currently selected name. You will be asked to confirm the deletion. 

Change name: shows a dialog window to allow changes to the details about this employee. 

Move name: allows an employee name to be moved up or down the list. 

Edit toolbar icons: enables customisation of the toolbar of planner icons, by adding or removing icons, or 
changing descriptions. 
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Clear column/Clear row: clears an entire row or column of icons at once (notes are not affected). 

Cut/copy/paste: these options allow entire areas of the planner (icons and/or notes) to be copied or moved 
at once. Once cut or copied, data can be pasted repeatedly. Icon changes can be undone in the usual way, 
but movement of notes cannot be undone. 

Move menu 

Home position: positions the planner with the current week as the leftmost week displayed, and the first 
name shown at the top. 

Start date: moves the planner to show the earliest week. 

End date: moves the planner to show the last week. 

Current date: moves the planner to show the current week as the leftmost week displayed. 

Month forwards: moves the planner forwards one month. 

Month backwards: moves the planner back one month. 

Top name: moves to the top of the planner. 

Last name: moves to the bottom of the planner. 

Symbols menu 

This section of the menu lists the symbols (icons) which are available to be placed on the planner grid. To 
use them, first select an area of the grid by dragging with the mouse. The selected area will be highlighted. 
Then select the icon you want from those listed on the menu. You can also select icons from the planner 
toolbar. 

Some menu items operate in a special way: 

Delete: this option will remove icons from the selected area. Column-wide icons cannot be removed this way 
(select Clear column from the Edit menu), nor can greyed out cells representing dates when an employee is 
not available (double-click the employee’s name to change these dates). 

Undo: this option will undo the last action (up to 20 actions may be undone) on the planner grid. Notes 
moved by cut/copy/paste actions cannot be undone. The Undo list is cleared after major changes to the 
names list, such as adding, deleting or moving names. 

Views menu 

Views allow you to see only part of a planner, to make management of large planners easier. Views may be 
instant (showing a single department or employee type) or personal (showing selected employees, 
departments and/or employee types). Your personal views are saved, and may be accessed from the main 
toolbar. You may also set some reports to use a view. 

Note that editing is restricted in a view: you can add, delete or change icons and notes, but you cannot make 
planner-wide changes, such as changing the planner date range, number of days in the week, number of 
daily time periods or add, delete, or move names on the employee list - you must return to the full planner 
view first. 

You can return to the full planner view at any time by clicking F5. 

Full planner: this option will always return you to the full planner from any view. 

Department: shows a list of departments - select one to switch to a view showing just employees in that 
department. 

Employee type: shows a list of employee types - select one to switch to a view showing just employees with 
that type. 
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Personal views: if you have previously created any personal views, they will be listed here - select the view 
you wish to switch to. 

Edit personal views: opens a dialog allowing you to create your own views, selected by employee name or 
by department and/or employee type. These views can then be accessed from the personal views button on 
the main toolbar.  

Options menu 

File details: opens the dialog allowing basic file details (titles, file path) to be changed. You can also switch 
between 5 and 7 day planner styles from this dialog, choose whether to show employee names only or 
departments/initials and whether reminders for birthdays, start dates and finish dates will display when the file 
is opened. Network files must be opened for editing first. 

Date range: shows a dialog window to allow the start and finish dates of the current planner to be changed. 
On a standard style planner, this allows out-of-date weeks to be removed and extra weeks to be added to the 
end of a planner. In this way, a planner may be used indefinitely. The planner style (standard/calendar 
year/fixed date) may also be changed. Network files must be opened for editing first. 

Daily time periods: shows a dialog window to allow the number or description of daily time periods shown on 
the planner for each employee to be changed. Network files must be opened for editing first. 

Statistics: select this option to view or print statistics about the number of occurrences or days used for any 
icon. You can select the employee names or departments and/or employee types to be included. Memorised 
statistics reports may be created, modified or deleted from this dialog. 

Custom icon management (Network version only): allows the compilation of files of custom icons, created 
in a standard drawing package such as Windows Paint, which are then available for customisation of toolbar 
icons for planners. Network files must be opened for editing first. See the Customisation section below for 
full details on creating and using custom icons. 

Preferences: shows a dialog for setting user options, such as date headings, colours, startup options, recent 
files and global settings. 

Help menu 

Contents: shows the Master Planner help file contents page. 

This screen: shows the help page relating to the main planner screen. 

Getting started: shows the help page relating to using the program after first installation. 

How to use Master Planner: shows the help page which gives a brief overview of the most important 
functions of the program. 

Open sample office planner: opens a planner showing how the program might be used for a small office. 

Open sample hotel planner: shows an example of a planner for a small hotel and restaurant, with room and 
table bookings, as well as staff shift planning. 

How do I?: shows the help page which answers some common questions. 

Register Master Planner: shows the dialog where you can enter registration information and find out more 
about registering Master Planner. 

About Master Planner: this shows the version and other information about the program. 

Dates 

The row of dates across the top of the planner shows the weeks which apply to this planner. Each date is the 
Monday of that week and there are either five or seven days to each week. You can change the way the 
dates are displayed by selecting Preferences from the Options menu and select the Dates tab. Change the 
background and highlight colours of the dates row by clicking the Colours tab. 
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When a planner of standard style is created, the first week on it will be the current week, so the first date will 
be the Monday of that week. For calendar year or fixed date style planners, the first date will be the Monday 
of the week before the week containing the start date of the planner. Whenever you open a planner, the 
leftmost week shown on the display will always be the current week. The second section of the status bar 
below the planner shows where you are, for example “Week 5 of 30: 14 Feb 2000”. 

You can view other dates on the planner by using the scroll bar below the planner, or using the arrow keys, or 

selecting Move on the menu bar, or by using the  and  buttons on the main toolbar. 

After a few weeks of use on a standard style planner, you will find that you have a lot of weeks on the planner 
that are now earlier than the current week, and you are running out of future weeks. Master Planner gives you 
the option of deleting out-of-date weeks and/or adding extra blank weeks to the end. Select Options then 
Date range from the menu bar. You will be offered the opportunity to backup the planner before making 
changes.  

You can change planner style at any time, switching between standard style (specified by a start date and a 
number of weeks), calendar year style (from 1st January to 31st December for a specified year) or fixed date 
style (with specific start and end dates). Your planner date range may be entirely in the future or past, if 
required. To change dates or styles, select Date range from the Options menu.  

Network files must be opened for editing before the date range or planner style can be changed. 

Names 

Down the left side of the planner is a list of employee names (or rooms, equipment or whatever is to be 
planned for). If there are no employees shown, this is an empty planner and you will need to add some 
employee names (select Add name from the Edit menu).  

The list can be displayed in two ways: showing the employee name or showing initials and department (or 
group, project, section, etc). To select your preferred option, select File details from the Options menu 
(network files need to be opened for editing first). Adjust the width of the columns using the + and – buttons. 

The currently selected line is highlighted in a contrasting colour, and described in the left section of the status 
bar below the planner. Select a line by clicking on it. You can also move the selection up or down by using the 
keyboard arrow keys. Scroll the list up or down using the scroll bar to the right, by using the keyboard arrow 
keys with shift held down, or by using the Page Up and Page Down keyboard buttons. You can also scroll by 

selecting Move on the menu bar, or using the and buttons on the main toolbar. Change the 
background and highlight colours of the names and dates by selecting Preferences from the Options menu, 
and clicking the Colours tab. 

Names cannot be added, deleted or moved while in a planner view; press the F5 key to switch to full planner 
view to make these changes. Network files must be opened for editing before names can be added, changed 
or deleted. 

Planner grid 

The planner grid shows icons representing employees activities. For each week of the planner, there are 
either five columns for Monday to Friday (alternate weeks may be shown in colour) or seven columns for 
Monday to Sunday (Saturday and Sundays may be shown in colour). For each employee, there are from 2 to 
12 rows, for activities in different time periods during the day (alternate employees may be shown in colour). 
The grid will only be displayed if there are employees on the planner. 

When a planner is first created and has some names added, it will be completely blank. You can view other 
parts of the planner by using the scroll bars below and to the right of the planner, or using the arrow keys, or 

selecting Move on the menu bar, or by using the      buttons on the main toolbar. 

To add icons or edit the planner grid, first open the planner toolbar by clicking the  button on the main 
toolbar. The toolbar will float above the planner, and can be moved around to a convenient location by 
dragging the small title bar with the mouse. Then select an area of the planner with the mouse, and click an 
icon. You can also use the Symbols section of the toolbar. Network files must be opened for editing before 
symbols can be added or removed. 
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If you see a  symbol on the grid, this indicates that Master Planner could not identify the correct icon to 
use. This may be because you have imported a toolbar file which does not contain this icon; or that the 
toolbar file is missing; or (for Network version users) that a custom icon could not be found. 

If you are unable to resolve this situation, call Ross Software for technical support (see the Troubleshooting 
section below). 

Status bar 

The status bar is shown below the planner. It contains four sections: 

Section 1: shows the currently selected line in the list of employees. 

Section 2: shows the leftmost date currently displayed. 

Section 3: shows the number of planner cells (squares) selected. 

Section 4: shows the contents of the planner cell (icon and note, if any) currently under the mouse, and also 
reports when a planner has been saved, AutoSaved, backed up, etc. 

Moving around the planner 

Scroll bars are provided where needed to enable you to move around. You can also move to the top, bottom, 
far left, far right and home position (top with current date) using buttons on the main toolbar. In addition, the 
Move option on the menu bar allows a range of movements, or use the keyboard shortcuts, as follows: 

Home    move to the home position (top, current week) 
End    move to the bottom of the planner 
Page up   scroll up one screenful 
Page down  scroll down one screenful 
Up arrow  move the name selection up one line 
Down arrow  move the name selection down one line 
Left arrow  scroll back one week 
Right arrow  scroll forward one week 
Shift + up arrow  scroll up one line 
Shift + down arrow scroll down one line 
Shift + left arrow scroll back 4 weeks 
Shift + right arrow scroll forwards 4 weeks 

Other keyboard shortcuts 

F5  returns to full planner view 
F6  opens the next personal view in sequence 

Ctrl-X  to cut icons 
Shift-X  to cut notes 
Ctrl-Shift-X to cut icons and notes 

Ctrl-C  to copy icons 
Shift-C  to copy notes 
Ctrl-Shift-C to copy icons and notes 

Ctrl-V  to paste icons 
Shift-V  to paste notes 
Ctrl-Shift-V to paste icons and notes 

Adding or changing names 

Names cannot be added, deleted or moved while in a planner view; switch to full planner view by pressing the 
F5 button to make these changes. Network files must be opened for editing before names can be added, 
changed or deleted. 
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Adding an employee name 

To add a new name to the planner, select Edit, then Add name from the menu bar, or click the  button on 
the edit toolbar. You will be shown a dialog box to add details about an employee. You can also add lines for 
booking shared office facilities, such as conference rooms, projectors or pool cars, or, by leaving the 
employee name blank, create a general department line. The Undo list is cleared after a new name is added. 

Name: type in the employee’s name, for example, John D Smith, John David Smith, J D Smith, John Smith, 
as preferred, or a suitable description (such as Conference Room 1). 

Initials or short name: the program will try to create the initials from the name, but you can modify them. 
You can also use this field for a nickname or short name. 

Group, section, project or department (optional): type in or select from the drop-down list of existing 
departments. You can leave this box blank, although this will be shown as “None” when you open this dialog 
in future. This information can be used to select employees for planner printouts, statistics or views. 

Employee type (optional): type in or select from the drop-down list of existing employee types. You can 
leave this box blank, although this will be shown as “None” when you open this dialog in future. This 
information can be used to select employees for planner printouts, statistics or views. 

 

Figure 5: changing details for an employee on the planner 

Start date, Finish date and Birthdate (optional): type in dates in any format valid on your computer: 3 Mar 
1998, 3/3/1998, etc, or click the arrow to show a pop-up calendar for easier selection. Dates when an 
employee is not available will be shown greyed out on the planner. When you open Master Planner, a pop-up 
box will remind you of any birthdays, or employees starting or leaving work that day (this option can be turned 
off; select File details from the Options menu). 

Phone and Email (optional): add contact details here, if required. 

When adding a new name, click Another to save these details and retain this dialog box to enter more details 
immediately. 
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Deleting an employee name 

To delete a name, select Edit then Delete name from the menu bar, or click the  button on the edit 
toolbar. You will be asked to confirm the deletion. The Undo list is cleared after a name is deleted 

Changing name details 

To change an existing name, select Edit, then Change name from the menu bar, or click the  button on 
the edit toolbar. You will be shown a dialog box to change details about an employee. You can change any of 
the information shown, except when in a planner view, when only date information may be changed (click F5 
first to return to full planner view). 

To move to another name in the list, click the > > >  button to move down or < < < to move up. Note that any 
changes will be retained when you move to another name record, but such changes will not be saved to file 
until the planner is saved or AutoSaved. 

Moving a name 

To move an employee (or other line) up or down the list, first select the name or initials by clicking; that line 

will now be highlighted in red. Now select Edit then Move name from the menu bar, or click the  button on 
the edit toolbar. 

The selected line will be shown in the centre of a subset of the current names list. Use the arrow buttons to 
move the line up and down the list. When you have positioned it in the correct place, click the OK button. The 
line and all associated icons and notes will be moved to the new position on the planner. The Undo list is 
cleared after a line is moved. 

Planners with no names 

If you have just created a new planner, or have opened a saved planner which has no names on it, you will 
be asked whether you want to add some directly or copy some from another planner (see figure 6). For files 
stored on the network server, you will be offered this choice only when you open the file for editing (click the 

 button to request authority to edit the file). Of course, you can also leave the planner empty for now if you 
wish.  

 

Figure 6: the empty planner file dialog 

If you choose to copy names from another planner, you will be able to select from a list of recently accessed 
planners, or browse your local or network drives. Note that on the Standard version, you will not be able to 
open planner files on a network server. Only the names and related information (each employee’s 
department, start date, finish date, birthdate and employee type) will be transferred: no planner icons will be 
copied, and the new planner dates will be unchanged. 
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To add a name at any other time, select Edit, then Add name from the menu bar, or click the  button on 
the edit toolbar. You will be shown a dialog box to add details about an employee. The Undo list is cleared 
after a new name is added. 

Adding or changing planner information 

Network files must be opened for editing before planner information can be added, changed or deleted (click 

the  button to request authority to edit the file). 

Adding symbols to the planner 

To add icons or edit the planner grid, first open the planner toolbar by clicking the  button on the main 
toolbar. The toolbar will float above the planner, and can be moved around to a convenient location by 
dragging the small title bar with the mouse. You can also use the Symbols section of the menu. 

Select the area of the grid where you want icons to be placed by dragging with the mouse. The area will be 
highlighted. Then click the button on the planner toolbar for the icon you wish to use (or select the option on 
the menu). The icons will be added to the planner grid. Note that some icons may be specified to be applied 
to all staff, so entire columns will be filled for the selected area (see below). 

The colour used to highlight the selected area on the grid may be changed; select Preferences from the 
Options menu and click the Colours tab. 

Symbols applying to an entire column 

Symbols may be set to apply to an entire column of the grid (for example, an activity which applies to 
everyone in your company, such as a bank holiday). In the default set of icons, the bank holiday symbol is the 
only one set to apply to columns. You can change this by selecting Edit toolbar icons on the Edit menu. 

Column-applicable symbols cannot be cleared or overwritten in the usual way. To remove a column of 
symbols, select one cell in the column, then click Clear column from the Edit menu. 

Removing symbols from the planner 

Select  the icons you want to remove by dragging with the mouse. The icons will be highlighted by a thin 

border. Now click the  button on the planner toolbar, or select the Delete option from the Edit menu, or 
press the Delete button on the keyboard. The selected area of the grid will be cleared. Note that icons 
applied to an entire column cannot be removed in this way (use the Clear column option on the Edit menu), 
nor can cells shown in light grey to indicate employee non-availability on that date (double-click the 
employee’s name and change the dates on the dialog box). 

Using cut, copy and paste with symbols 

First select the cell, or block of cells, with symbols to be cut or copied and use one of the following keyboard 
shortcuts: 

Ctrl-X  to cut icons 
Ctrl-C  to copy icons 
Ctrl-Shift-X to cut icons and notes 
Ctrl-Shift-C to copy icons and notes 

Then select the top left cell of the area to be pasted to, and type: 

Ctrl-V  to paste icons 
Ctrl-Shift-V to paste icons and notes 

There is no undo facility for notes moved using cut, copy and paste. Pasted notes will be appended to any 
existing notes; to avoid this effect, clear the area first using the cut notes facility. You can, of course, repeat 
the paste action as many times as you want. These functions are also available from the Edit menu. Icons 
applicable to an entire column (such as bank holidays) and non-availability cannot be edited in this way. 



How to use Master Planner 

 Page 20

Greyed-out areas showing non-availability 

When an employee is not-available for tasks for certain dates, planner cells are greyed out on those dates, 
and the usual addition or removal of symbols has no effect. This occurs when you specify start and/or finish 
dates for an employee. For example, you might add a newly recruited employee to the planner with a starting 
date; s/he will be shown with greyed-out cells for all days before the start date.  

You may also see greyed-out cells if you have specified exact start and finish dates for your planner, such as 
a calendar year. Master Planner adds an additional complete week to the beginning and end of the planner, 
so that you can see your exact start and finish dates, and all days outside these dates will appear grey for all 
employees. 

Missing symbols 

If you see the symbol anywhere on the planner, this indicates that Master Planner cannot identify the 
required symbol. It may mean that a custom icon bimap cannot be located (network version only), or that you 
have inadvertantly removed the corresponding icon from the planner toolbar, or that a saved toolbar file 
cannot be found. 

If you are unable to resolve this situation, call Ross Software for technical support (see the Troubleshooting 
section below). 

Adding a text note to a planner cell 

A text note may be added to any cell on the planner, whether it has an icon or not - double-click the cell, type 
your message and click OK.  

 

Figure 7: adding or changing a text note on a planner cell 

Cells with notes attached are flagged with a small coloured triangle in the top right corner. When the planner 
is active, hovering the mouse over a cell with a note will display the contents of the note as a tooltip (click any 
cell to make the planner active). Alternatively, a single click on a cell will display details of that cell, including 
any note, in the right portion of the status bar below the planner. Network files must be opened for editing 

before a note can be added (click the  button to request authority to edit the file). 

Deleting a note 

To delete a note, double-click the cell with the note and click the Delete button. Alternatively, read through all 
the notes on a planner sequentially (that is, in date order) by selecting File then Read notes on the menu 
bar. Use the arrow buttons to scroll through the notes. You can delete any or all notes. Network files must be 

opened for editing before a note can be deleted (click the  button to request authority to edit the file). 

Changing a note 

To change a note, double-click the cell with the note, make your changes and click OK. Alternatively, read 
through all the notes on a planner sequentially (that is, in date order) by select File then Read notes on the 
menu bar. Use the arrow keys to scroll through the notes. You can change any or all notes. Network files 
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must be opened for editing before a note can be changed (click the  button to request authority to edit the 
file). 

Using cut, copy and paste with notes 

First select the cell, or block of cells, with notes to be cut or copied and use one of the following keyboard 
shortcuts: 

Shift-X  to cut notes 
Shift-C  to copy notes 
Ctrl-Shift-X to cut icons and notes 
Ctrl-Shift-C to copy icons and notes 

Then select the top left cell of the area to be pasted to, and type  

Shift-V  to paste notes 
Ctrl-Shift-V to paste icons and notes 

There is no undo facility for notes moved using cut, copy and paste. Pasted notes will be appended to any 
existing notes; to avoid this effect, clear the area first using the cut notes facility. You can, of course, repeat 
the paste action as many times as you want. These functions are also available from the Edit menu. Icons 
applicable to an entire column (such as bank holidays) and non-availability cannot be edited in this way. 

Reading all notes 

To read through all the notes on a planner sequentially (that is, in date order), select File then Read notes on 
the menu bar. Use the arrow keys to scroll through the notes. You can change or delete any or all notes. 

Printing notes 

You can print all notes on a planner in sequential (date) order by selecting Print notes from the File menu. 
Alternatively, click the Print selected notes option and select from one of the predefined date ranges listed. 
Both these options use the current printer settings for font, orientation, number of copies, etc. 

To refine your selection even further, choose the Print option to open the print wizard and click the Print 
notes option. You will be able to select an exact date range to print, as well as adjusting the printer settings. 
See the Printing section below for full details. 

Planner files 

Network files must be opened for editing before planner files can be changed or deleted (click the  button 
to request authority to edit the file). 

Creating a new planner 

To start a new planner, select File then New on the menu bar, or click the  button on the main toolbar. 
You will be given the opportunity to save any changes to your existing planner. A wizard will guide you 
through the process of creating a new planner. You will be able to make changes later. 

Planner name and save location: select one or two names to describe your planner. You may also specify 
where the planner is to be saved (see figure 8). 

 

Planner size and format: select from three planner styles (you will be able to change your choice later): 

 Standard - specify the number of weeks (from 4 to 150), starting from the current week(see figure 9). 
You will be able to add additional weeks to the end of the planner and remove out of date weeks from 
the start; in this way your planner may be used indefinitely.  

 Calendar year - 1st January to 31st December only for your chosen year (this does not have to be the 
current year - see figure 10).  
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 Fixed date - you specify the exact start and finish dates, so you can use financial, academic, fiscal or 
company dates (see figure 11). 

 

Figure 8: setting the names for a new planner 

 

Figure 9: creating a standard style planner 
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Figure 10: creating a calendar year planner 

 

Figure 11: creating a fixed date planner 

You can also choose whether to have 5 days per week on your planner (Monday to Friday) or 7 (Monday to 
Sunday). Use the colours option to display alternate weeks in colour (5 day week) or to show weekends in 
colour (7 day week); a range of colours is available by selecting Preferences from the Options menu (see 
the section Customisation below). 

You can specify from 2 to 12 daily time periods. Each daily time period represents a block of time for which 
you wish to assign activities for employees or resources, and is shown as a row of cells on the planner grid. 
The daily time periods do not need to represent equal amounts of time, or actual work shifts. Initially 2 daily 
time periods are defined, set to Morning and Afternoon; type new descriptions to add more daily time periods, 
or double-click on the list to change a description. Highlight a description and press the Delete key to delete a 
description.  

Bear in mind that the more daily time periods you have, the fewer employees can fit on the planner screen or 
report pages. You will be able to change the number and descriptions of daily time periods later; Select Daily 
time periods from the Options menu. 

Toolbar icons to use: a new planner will normally be created with a default set of toolbar icons, containing a 
mixture of the most common symbols and colours appropriate to an office environment. One symbol is 
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specified for bank holidays, and applies to all employees (that is, when used it will fill complete columns, not 
just the selected area). 

 

Figure 12: selecting an icon set for a new planner 

If you have used Master Planner before, you can copy a previously saved standard set of icons, or copy a set 
from an existing planner. Network version users can also browse local or network drives for saved toolbar or 
custom icon files (see figure 12). 

You will be able to change the icons on the planner toolbar and their descriptions later; select Edit toolbar 
icons from the Edit menu. 

 

Figure 13: copying names to a new planner 

Copy names option: if you have used Master Planner before, you can copy a list of employee names from 
an existing planner to the new planner (see figure 13). Only the names and related information (each 
employee’s department, start date, finish date, birthdate, employee type, phone number and email address) 
will be transferred: no planner icons will be copied, and the new planner dates will be unchanged. 

Title bar/columns in employee list/show messages on opening: choose what to display on the title bar 
when Master Planner runs, the columns to show in the employee list and whether to show date reminder 
messages when the planner is opened (see figure 14). 
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Figure 14: setting options for a new planner 

Click Finish to create your planner. If you did not copy any names, the planner will be empty and you will be 
asked if you want to add some names (you will not be able to add symbols to an empty planner). You can add 
names later by selecting Add name from the Edit menu. 

It is a good idea to make any changes to the toolbar icons now, before adding symbols to the planner - select 
Edit toolbar icons from the Edit menu. 

Opening a different planner 

You may have any number of planners. When Master Planner first loads, the default file will be opened for 
you automatically. There are three ways to open a different planner (you will be offered the opportunity to 
save any unsaved changes to the planner already open): 

1: Select a recent file: on the menu bar, select File, then select from the list of up to ten recently accessed 
planners.  

2: Use the menu bar: select File on the menu bar, then select Open. You will be presented with a dialog box 
showing a list of recently accessed planner files (see figure 15). Double-click to select one, or click the 
Browse button to open the standard file dialog box, which will enable you to search your local or network 
drives. 

 

Figure 15: selecting a planner file to open 

3: Click the toolbar button: on the main toolbar, click the  button. You will be presented with the open file 
dialog box (see figure 15). Select a file from the list and click OK, or browse for the file you require. 
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The existing planner will be cleared and you will be shown the progress of the file-opening process in a status 
bar, similar to that shown on the Master Planner load screen. 

If any error occurs while trying to open the selected planner, you will be shown a message and the previous 
planner will continue to be displayed. You should check that the selected file is in fact a Master Planner file 
(the default extension is .mpf), and that the drive where the planner is located is available (for example, you 
may have the wrong disk or no disk in the floppy drive, the network may have shut down, etc). Note that when 
running the Standard version of Master Planner, you will not be able to open planner files held on a network 
server. 

The default planner file 

In normal running, Master Planner always requires a planner file to display; the file specified to be opened 
when the program first loads is the default planner file, which is opened automatically from information stored 
in the configuration file (mastplan.ini). When you first install Master Planner, the first file you create and save 
will be set to be the default file. 

To change your default file, first open the planner file you want to be the default. In the Options menu, select 
File details then click Next until the default file check box appears. Tick this box, then click Finish. Next time 
you open Master Planner, this file will open automatically. 

If the default file cannot be found when Master Planner loads, an error message will explain the problem and 
you will be offered the choice of creating a new planner file, browsing for a different file or closing the 
program. Be sure to specify a planner as your new default file as described above, to avoid this problem 
recurring. 

Opening Master Planner minimised to the system tray 

To ensure that whenever you open Master Planner, it will show as an icon in the sytem tray (alongside the 
clock), rather than on your desktop, select Preferences from the Options menu, and select the Global tab. 
Check the option Show program icon in system tray.  

Note that selecting this option applies to all planners you open, including the default planner file, and 
overrides any shortcut or AutoRun settings. 

Note that when run from the system tray, the program can only be closed from the system tray context menu; 
closing the program window returns it to the system tray. For network files, the system tray icon will show 
yellow when another user has made changes to the planner file; click the traffic light icon to refresh the 
planner with the latest information. 

Opening a specific planner file with a shortcut 

If you have more than one planner file, you may want to choose which one to open, and override the default 
file setting. To do this create a shortcut in a folder or on the desktop or Start menu to the Master Planner 
executable and add the required file path to the target in the dialog, leaving a space between the two file 
paths. Your target will look something like this: 

 “c:\Program Files\Master Planner\mastplan.exe” c:\My Files\My Planner.mpf 

If you want to keep a planner open all day for quick access, but without cluttering your desktop, you can have 
Master Planner open conveniently minimised to the task bar (alongside the Start button) or to the system tray 
(alongside the clock). To do this add an additional parameter to the target: 

 “c:\Program Files\Master Planner\mastplan.exe” /s c:\My Files\My Planner.mpf 

Note that there should be a space either side of the /s parameter. The /s parameter will run the program 
minimised to the system tray. Other options are /m which runs the program minimised to the taskbar, or /n 
which runs normal size (the default), but note that the program may still appear in the system tray if you have 
selected the global setting, described in Opening Master Planner minimised to the system tray, above. 

Note that when run from the system tray, the program can only be closed from the system tray context menu; 
closing the program window returns it to the system tray.  
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For network files, the system tray icon will show yellow when another user has made changes to the planner 
file; click the traffic light icon to refresh the planner with the latest information. 

Alternatively, you can associate the mpf file extension (or your own choice of extension) with Master Planner. 
This enables planner files to be opened directly from Windows Explorer. See the Windows Help file or your IT 
advisor if you need help with these options. 

Network version users can create shortcuts to an existing planner file on the Start menu or desktop during 
client installation (see the section Installing Master Planner for more information). 

Automatically opening a planner when Windows starts 

You can set a planner file to be opened automatically whenever Windows starts, either normal size, 
minimised to the taskbar (the area next to the Start button) or minimised to the system tray (the area next to 
the clock). This enables you to have your planner always available.  

To set this option for an existing planner, first open it and then select Preferences on the Options menu and 
select the Startup tab. Some versions of Windows require administrator’s rights when changing this option. 

Note that when run from the system tray, the program can only be closed from the system tray context menu; 
closing the program window returns it to the system tray. Note also that if you set the file to open normal size 
or minimised to the taskbar, the program may still appear in the system tray if you have selected the global 
setting, described in Opening Master Planner minimised to the system tray, above. 

For network files, the system tray icon and the traffic light icon on the main toolbar will show yellow when 
another user has made changes to the planner file; click the traffic light icon to refresh the planner with the 
latest information. 

Note that Master Planner is a graphical program, making heavy use of system resources. You should be 
cautious about having several planners open simultaneously as your system may become unstable. 

Saving a planner file 

To save any changes made to the current planner, click Save or Save as on the File menu. If you selected 
Save as or you have not previously saved this planner, you will be shown the standard Windows directory 
browse dialog to enable you to select a save location. The status bar below your planner will indicate that the 
planner has been saved successfully. 

You will always be prompted to save any unsaved changes before you close Master Planner, or open a 
different planner. You may also choose to have your changes saved automatically; to do this, select 
Preferences from the Options menu and select the Global tab. 

AutoSave option 

An option which enables a planner to be saved automatically. The current AutoSave setting is saved in the 
configuration file (mastplan.ini) and applies to all planners you open for which you have editing rights. When a 
planner is automatically saved, a message will be shown in the right portion of the status bar below the 
planner. There are 5 settings: 

Off: the planner will only be saved when you request it (you will be prompted to save any unsaved changes 
before opening a different planner or exiting the program). 

Save on exit: the planner will automatically be saved when opening a different planner or exiting the program 
(you will not be prompted). 

Save on change: any changes you make will be saved immediately. 

Save every 5 minutes: the planner will automatically be saved every 5 minutes. 

Save every 1 minute: the planner will automatically be saved every minute. 

To change AutoSave settings, select Preferences from the Options menu and select the Global tab. Note 
that for network files, the AutoSave option will only be active while the file is open for editing. 
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Backing up a planner file 

You can of course use your own backup procedures for Master Planner files if you wish, but backup and 
restore options are available if required. There is also a QuickBackup option, which enables an instant 
backup to be made (see the next section below). Note that only planner, toolbar and custom icon bitmap files 
may be backed up and restored using Master Planner’s inbuilt facilities: the configuration file (mastplan.ini) is 
not backed up (it will be recreated if missing). 

 

Figure 16: backing up a planner 

To backup a planner, either select File then Backup from the menu bar or, if QuickBackup is not enabled, 

click the  button on the main toolbar. You will be shown the backup dialog window (see figure 16).  

Either type in an appropriate file path or click the Browse button to select a path from your local or network 
drives. Click Backup to save the current settings and backup the current file to the selected file path. If your 
planner uses a separately saved toolbar file, or (for Network version users) any custom icons, these will be 
backed up to a toolbar directory in the same location as the backed-up planner file. Click Apply to save the 
current settings without backing up. 

If Quick Backup is enabled, click the  or  button; a backup will be made immediately and a message 
displayed on the right portion of the status bar below the planner. 

QuickBackup option 

An option which enables an instant backup of the current planner, using the current settings, from the main 
toolbar. QuickBackup is enabled from the backup dialog (select File then Backup from the menu bar). The 
toolbar buttons show whether QuickBackup is enabled:  

 Shows backup dialog window (QuickBackup disabled) 

 Backs up the planner now to a floppy drive (QuickBackup enabled) 

 Backs up the planner now to a local or network drive (QuickBackup enabled) 

When QuickBackup is enabled, you can make an immediate backup of the current file by clicking the toolbar 
button; the planner will be saved to the specified backup location. The status bar shows the outcome of the 
backup operation. 

Restoring a planner file 

You can of course use your own backup procedures for Master Planner files if you wish, but backup and 
restore options are available if required. Note that only planner,  toolbar and custom icon bitmap files may be 
backed up and restored using Master Planner’s inbuilt facilities: the configuration file (mastplan.ini) is not 
backed up (it will be recreated if missing). 
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To restore a planner, select File then Restore from the menu bar. You will be shown the restore dialog 
window. Either type in an appropriate file path or click the Browse button to select a path from your local or 
network drives. 

Click Restore to restore the selected file. The planner file will be restored immediately, overwriting the 
existing planner file. If your planner uses a separately saved toolbar file, or (for Network version users) any 
custom icons, these will also be restored to their original locations, overwriting any existing files. Network 
version users are advised to use their company’s standard backup and restore procedures for all files held on 
the network server. 

The configuration (INI) file 

Master Planner stores information about your personal program preferences (such as default print settings, 
personal views, startup options, recent files, colour options and so on) in a configuration or initialisation file, 
mastplan.ini, stored in the Windows directory. Note that file-specific settings are stored in the planner file. The 
INI file is not essential; if missing it can be recreated. If it becomes corrupted, simply delete it and allow 
Master Planner to recreate it with default settings when it is next run. It is not included in Master Planner’s 
built-in backup routines, but if you have your own backup procedures, you may wish to include this file to 
preserve your personal settings. 

Note that the location of the default file to open is stored in the configuration file. Should the configuration file 
be deleted, Master Planner will be unable to determine which planner file to open by default, and a dialog will 
offer you the option to browse for a planner file, create a new one or exit. If you have a planner file you wish 
to use as the default, browse to that file and open it. You should then reset it as the default by selecting 
Preferences from the Options menu, and clicking the Startup tab. 

Toolbar files 

The planner icons toolbar contains all the symbols (icons) available to be added to a planner. Master Planner 
provides a default set of icons, for general office use, but you can customise the toolbar by changing 
descriptions, adding extra icons from a large built-in range and removing any not required. Network version 

users may also create their own icons. Select Edit toolbar icons from the Edit menu, or click the  button 
on the Edit toolbar to customise the toolbar (see figure 17; also see the Customisation section for full 
details). 

 

Figure 17: customising and saving a planner toolbar 

Each planner can have a different toolbar, or several planners may use the same toolbar. When you 
customise your planner icons toolbar, you can choose whether to keep the customised toolbar details with the 
planner file (if you have only one planner or wish each planner to have a different toolbar), or to save the 
toolbar details to a separate file, which can then be imported into any other planner. 
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A saved toolbar file normally has a .tlb extension. Standard version users may only have one saved toolbar 
file, which is called mastplan.tlb and is saved in the same location as the Master Planner program file 
(mastplan.exe). Network version users may have any number of toolbar files and can save to any local or 
network drive. Toolbar files are backed up and restored by Master Planner’s built-in facilities. 

Note that once a planner toolbar is saved as a separate file, the toolbar file must be available whenever that 
planner is opened in Master Planner. This will become a consideration if a planner file normally held on the 
server is copied to a local drive or emailed to a colleague out of the office for use in stand-alone mode.  

The path of a separate toolbar file is stored in the planner file; if it cannot be found, the program will search 
the directories of the program and the planner file. If these also fail, an error will be raised and the program 
will fall back on the default toolbar set. If any symbols used on the planner are not on the default set, they will 
display as  on the toolbar and/or planner. 

Accessing network files (Network version) 

The Network version of Master Planner may be run from a network server, and files may also be held on the 
server if necessary. Any number of users may view a network-held planner at once, but only one user at a 
time may edit a file. Use your network software to determine who has read-write access and who has read-
only access. Master Planner will disable editing functions for those with read-only access. The traffic light 
button on the main toolbar indicates the status of the current planner: 

 Planner cannot be edited; click to open for editing. 

 Planner has changed since it was opened; click to refresh. 

 Planner may be edited; after making changes, save the file then click to release the planner for other 
users to make changes. The changes will be notified to other users (their traffic light will turn yellow) 
reminding them to refresh. 

WARNING: the file is locked when the green traffic light shows - no other user can edit it. Always 
release the file as soon as you have finished making changes. 

Custom icon files (Network version only) 

Network version users may create their own custom icons for use on a planner toolbar (see the Creating 
your own icons section in Customisation). These are standard Windows bitmap files, which normally have 
a .bmp extension.  

Once created, the details of the custom icons are compiled into a custom icon data file, which can be opened 
on the Custom tab of the icon editing screen (opened by selecting Edit toolbar icons from the Edit menu). 
This means that custom icons can be added to a planner toolbar as easily as the built-in icons. Custom icon 
data files normally have a .dat extension, and you may have any number of them. 

Any custom icons bitmap files used by a planner will be backed up and restored by Master Planner’s built-in 
facilities. The custom icon data files are not backed up, however. You are advised to use your company’s 
standard backup and restore procedures for all files held on the network server. 

Note that once custom icons are added to a planner toolbar, the icon bitmap files must be available whenever 
that planner is opened in Master Planner. This will become a consideration if a planner file normally held on 
the server is copied to a local drive or emailed to a colleague out of the office for use in stand-alone mode. If 
any icons are not available, they will display as  on the toolbar and/or planner. 

Sharing files with users not on the network (Network version only) 

Sometimes Network version users may wish to share Master Planner files with users who are working from 
home, visiting clients or otherwise out of reach of the network. To do this, follow these steps: 

1) Install Master Planner as a stand-alone copy on the user’s laptop computer. 

2) If any planner files use a separate toolbar file, copy this to the user’s computer, in the same directory as 
the program (mastplan.exe). 

3) If any custom icons are used, copy all the required bitmap files to the user’s computer, also to the same 
directory as the program (mastplan.exe). 
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4) As often as needed, attach the planner files to an email and send to the user. 

5) If the user will also access network files, separate shortcuts should be created to the network and copied 
files, clearly marked as such. 

WARNING: as with all files, only one master version of a planner file may exist; copies should be 
regarded as read-only and no changes should be made to shared files away from the network. The 
Master Planner file-sharing functions (operated by the traffic light icon) do not operate on copied files 
held locally. 

If users find themselves out of reach of email, the planner and various reports may be printed and sent by 
fax. To facilitate black-and-white transfer, an option to switch off colour printing is provided, so that icons print 
as numbers rather than graphics. When printing the planner this way, be sure to print the one-page symbols 
key as well. 
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Section 3: Planner views and statistics 
What are planner views? 

A planner view is a way of seeing just a part of a planner, that is, only some employees. If you have a large 
number of employees on the planner, moving up and down the list can be time-consuming. A view allows you 
to see just the part of the planner you need. Your current view is shown at the top right of the planner screen.  

A planner view may be instant, selecting a single department or employee type from the Views menu, or you 
can create personal views, selecting employees to include by department and/or by employee type. Views 
may be used when compiling statistics and some reports. 

You can make changes to icons and notes on the planner from within a view, but you must switch back to the 
full planner to make planner-wide changes, such as adding, deleting or moving employees or changing the 
date range, number of daily time periods or days in a planner week.  

Viewing part of the planner 

Switch to a view of a single department or employee type by clicking View on the menu and selecting the 
department or employee type to view.  

Returning to the full planner 

You must return to the full planner view (showing all employees) before you can make planner-wide changes, 
such as adding, deleting or moving employees or changing the date range, number of daily time periods or 
days in a planner week. 

To return to the full planner, press the F5 key, or select Full planner from the Views menu, or, if you have 

created personal views, click the  button on the main toolbar repeatedly until the full planner is displayed. 

Using personal views 

Personal views allow you to see just those employees you have selected (by department and/or employee 
type) on the planner. You can specify any number of personal views, moving from one to the next using the 

 button on the main toolbar or selecting from the Views menu or by pressing the F6 key. The current view 
name is displayed in the top right of the planner screen. Return to the full planner at any time by pressing the 
F5 key. 

Your personal views settings are stored in the Master Planner configuration (INI) file and are not available to 
users on other machines, even when accessing the same planner. Each user may specify any number of 
personal views for each planner.  

One of your personal views is set as the default view, which is the view opened when you first open that 
planner. Initially, the full planner is the default view, but this may be changed at any time. 

Creating personal views 

Personal views, defined by your selection criteria, can be displayed by clicking the  button on the main 
toolbar or by selecting the required view from the Views menu or by pressing the F6 key. 

To create a personal view, select Edit personal views from the Views menu and click the Add button. 
Choose a suitable name for the view and select the departments and employee types to include. You can 
also specify a view to open by default whenever you open this planner file. Click OK to keep this view (see 
figure 18). 
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Figure 18: creating or changing a personal view 

Changing personal views 

To change or delete a personal planner view, select Edit personal views from the Views menu (see figure 
18).You can make changes to a view name or the departments and/or employee types to select. You can 
also delete unwanted views (except the full planner view) and change which view opens as the default. You 
do not have to be in a view to edit it. 

Setting a default personal view 

The default personal view is the one that is opened automatically whenever you open this planner. Initially, 
this will be the full planner view, but once you have created one or more personal views, you can choose a 
different default. To change this setting, select Edit personal views from the Views menu, select a view by 
clicking it in the list and click the Make Default button. 

You can also change the default startup view by selecting Preferences on the Options menu, and clicking 
the Startup tab. 

What are icon usage statistics? 

Icon usage statistics allow you to find out how much an icon (symbol) has been used on the planner. For any 
icon, you can select individual employees or entire departments or employee types, a date range and specify 
how you want to view the results. 

For example, you can find out the amount of sick leave taken by staff in the Accounts department during July, 
or the amount of time spent on a specific project by all staff during the year. A blank icon is provided so that 
you can find out which staff have time not assigned to any tasks. The results can be printed and the selection 
criteria may be saved as a memorised report for easy printing later. 

Creating statistics 

Select Statistics on the Options toolbar to open the statistics dialog. Specify your choice of selection and 
presentation criteria from the tabs, as shown below. 

Icon tab: click the icon you want statistics for, or the blank button to find out about availability (see figure 19). 
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Figure 19: selecting an icon for usage statistics 

Select tab: select one or more employees, departments or employee types to include. You can select from 
the current view, a personal view if you have created any or the full planner (see figure 20). 

Dates tab: select a date range to include. You can specify exact dates using the pop-up calendar (see figure 
21). 

Options tab: select how you want the results presented (see figure 22). 

Printing tab: select print options (see figure 23). 

The results are automatically recalculated after each selection you make. If recalculation is slow, uncheck the 
Calculate on change box and click Calculate when you have made all selections.  

Occasionally, changing an option clears the existing selection criteria. If the results pane shows “No 
selection”, you should open the Select tab to make a selection. 

Click the Clear button to clear the current selection criteria and compile a new set of statistics. 
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Figure 20: selecting employees to include in statistics 

 

Figure 21: selecting dates for icon statistics 
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Figure 22: selecting results options for icon statistics 

 

Figure 23: selecting print  options for icon statistics 
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Viewing and printing statistics 

The results pane in the statistics dialog shows the usage of the specified icon for the selected employees 
during the chosen date range. You can choose to compile statistics by exact numbers (which counts 1 for 
each occurrence of a symbol) or by days (which counts a whole day for several occurrences of a symbols - 
for example, if your planner has 4 daily time periods, then 4 occurrences of a symbols counts as one day, 
although they need not all occur on the same day). 

Results are shown with the highest numbers first, and you can choose to show summaries for departments 
and/or employee types as well. Zero results can be suppressed and the results may be printed. See the 
Printing section below for full details. 

Memorised statistics reports 

Any statistics report may be memorised; click the Memorise button to give the report a name. The selected 
icon, employee selection criteria, date range, display options and print settings will all be saved, and the 
report now appears on the drop-down list of memorised reports.  

The report will also appear on the list of memorised reports available for instant printing on the File menu of 
the planner screen. The report may be reprinted at any time, using the same selection criteria and your 
chosen print settings, by clicking the appropriate menu option. 

To change the report selection or printing criteria, select the report in the drop-down list in the statistics 
window, click the Open button and make any changes you require. Click the Memorise button to save the 
changes. You can also save the changes as a new report by changing the report name after clicking the 
Memorise button. 

The report can also be set to use default print settings, if preferred; check the Use default print settings box 
while the report is open. Check the QuickPrint box to allow this report to be printed instantly by clicking the 
print toolbar button on the main planner screen (this option may also be turned on from the print wizard - 
select Print from the File menu). Remember to click Memorise to save these changes. 

Note that memorised reports are saved as part of the planner file, however the default print settings and 
QuickPrint selection are personal to each user and are saved in the configuration file (mastplan.ini). Network 
version users should note that memorised reports based on a personal view can only apply to local files; for 
network files, only the current view or the full planner may be specified.  

Network files must be opened for editing before statistics reports can be memorised, or memorised reports 

changed or deleted (click the  button to request editing authority). 
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Section 4: Printing 
Master Planner can produce a number of printed reports. The print wizard, accessed from the Print option on 
the File menu, allows detailed specification of most reports, and also allows you to save default printer 
settings and memorise reports. Memorised  reports and a number of instant reports can also be printed 
automatically, from the menu or toolbar, using the default printer settings. 

Reports available 

Print a section of the planner 

A planner report prints a section of the planner, from 3 to 8 weeks, in the grid style of the screen display, 
showing names, dates and planner symbols. You can select which employees to include and the start date of 
the section to be printed. Available from the print wizard; this report may also be specified as your QuickPrint 

report and printed by the  button on the main toolbar if QuickPrint is enabled (see the QuickPrint section 
below). 

Print a key to the symbols 

Prints a 1-page report, showing all the symbols and descriptions currently on the toolbar for this planner 
(whether in use on the planner or not). Available from the print wizard and the Print symbols key option on 
the File menu. 

Print notes 

Prints notes, also showing the symbol and description for the cell, in date order. You can select which 
employees to include and a date range. Available from the print wizard and from the File menu; this report 

may also be specified as your QuickPrint report and printed by the  button on the main toolbar if 
QuickPrint is enabled (see the QuickPrint section below). 

Print personal schedules 

Prints a schedule for an employee showing, in grid form, both symbols and notes for each day. You can 
select which employees to print schedules for, and a date range. Each employee’s schedule prints on a new 
page. Available from the print wizard and, for the currently highlighted employee on the names list, from the 

File menu; this report may also be specified as your QuickPrint report and printed by the  button on the 
main toolbar if QuickPrint is enabled (see the QuickPrint section below). 

Print weekly schedules 

Prints a schedule for one or more weeks showing, in grid form, both symbols and notes for each daily time 
period. You can select which employees to include on a schedule report, and a date range. Each week’s 
schedule starts printing on a new page. Available from the print wizard; this report may also be specified as 

your QuickPrint report and printed by the  button on the main toolbar if QuickPrint is enabled (see the 
QuickPrint section below). 

Print icon usage statistics 

Prints the data shown in the results page of the icon usage statistics screen, obtained by selecting Statistics 
from the Options menu. Available from the statistics screen, or  from the print wizard for memorised reports; 

this report may also be specified as your QuickPrint report and printed by the  button on the main toolbar if 
QuickPrint is enabled (see the QuickPrint section below). 

Printing with the print wizard 

Open the print wizard by selecting Print from the File menu. If QuickPrint has not been enabled, the  
button on the main toolbar will also open the print wizard. 



Printing 

Page 39 

Selecting a report: choose to print a planner section, a key to the symbols, notes, weekly or personal 
schedules, a memorised report or the last report printed. You can also view or change default print settings. 
When printing the planner, notes, weekly or personal schedules, if you have set up personal views, you can 
also choose whether to use a view or the full planner (see figure 24). Your report will not be printed until you 
click the Print or Print now button. 

 

Figure 24: selecting a report to print 

Selecting a memorised report: if you selected the Print a memorised report option on the first page of the 
print wizard, you can now select a memorised report to be modified or printed (see figure 25). Any memorised 
report may be printed immediately using the settings specified in that report by clicking the Print now button.  

Alternatively, you can review settings and make changes to most reports (only limited changes may be made 
to the default (first) memorised report; statistics reports should be changed in the statistics screen). 

The first memorised report is always an instant planner report, printing all names on the current planner view 
and using the current planner position. This report cannot be deleted, or the selection criteria changed; this 
ensures that an instant planner printout is always available for use as a QuickPrint report for users of network 
files. Settings affecting the appearance of the report (font, number of lines or weeks per page, page breaks 
and so on) may be changed. This is normally the default QuickPrint report. 

Users of earlier versions of Master Planner who used the QuickPrint option, or saved selection details for 
planner reports, may have a second memorised report (called ‘Selected planner print’) as their default 
QuickPrint report. This initially prints the currently visible section of the planner using the selected 
departments and/or employee types, but may be modified or deleted as required. 

Any other memorised reports you have previously saved will also be shown. If you have already printed a 
report in this session of Master Planner, details of the last report printed will also be shown (this information 
will be lost when you close Master Planner); this enables the report to be modified for subsequent reprinting, 
or memorised at any time. 

Memorised icon statistics reports are also shown here, but most settings can only be modified in the 
Statistics screen; select Statistics from the Options menu. However, they may be deleted or set as a user’s 
QuickPrint report here, and the choice of default or specified print options may also be set. 

Network users should note that any user may print a memorised report, or modify it in order to print a different 
version of it; however, the planner file must be open for editing before any changes can be saved. 



Printing 

 Page 40

 

Figure 25: selecting a memorised report to print or modify 

Memorised report settings may be changed as follows: 

Name: the report name may not be changed. To change the name, click the Memorise button, and save the 
report under a new name. You can then delete the original report. 

Type: the report type may not be changed. To change the type of a report, create the new report of the 
required type and delete the old report. 

View: specify whether the report should use the full planner or the current view. For local planner files, you 
may also specify a personal view; if the view cannot be found when the report is printed later, the current view 
will be used. 

Use default print settings: if checked, the report will use the current default print settings; if unchecked, the 
settings specified in the report will be used. Network users should bear in mind that default print settings are 
a user setting, stored in the INI file; to obtain a uniform appearance for reports, leave this box unchecked and 
specify the settings individually for each report. 

QuickPrint: check to set the highlighted report to be your QuickPrint report, if QuickPrint is enabled. This is a 
personal setting, stored in the INI file. Enable QuickPrint from the final page of the wizard; this will show the 

 button on the main toolbar to permit your chosen report to be printed instantly. If your selected QuickPrint 
report cannot be found when required for printing, the default QuickPrint report (the first memorised report) 
will be printed instead. 

Use exact date (planner reports only): check to always use the specified dates when printing this report. If 
left unchecked, the report will print the currently visible section of the planner. 

Delete: click to delete the highlighted report (you will be asked to confirm). The report will no longer be 
available, but will not be permanently deleted until the planner file is next saved or AutoSaved. 

Selecting names, departments or employee types (planner, personal and weekly schedule reports 
only): select individuals by name, or entire departments, or staff of selected employee types. For planner 
reports, you can also specify the number of names to be printed per page, and whether you want to start 
each department and/or employee type on a new page (see figure 26). Any memorised report may be printed 
immediately using the current settings by clicking the Print now button.  

On the default (first) memorised report, no changes may be made to the selection of names, departments or 
employee types as all names are automatically included. The settings for lines per page and page breaks 
may be changed. 



Printing 

Page 41 

 

Figure 26: selecting employees to include in a report 

Selecting dates (planner, notes, personal and weekly schedule reports only): for planner reports, select 
the number of weeks of the planner to print (3-8). For notes, weekly and  personal schedules, select the date 
range to cover (see figure 27). Any memorised report may be printed immediately using the current settings 
by clicking the Print now button.  

On the default (first) memorised report, the start date may not be changed, as the report always prints the 
currently visible section of the planner. 

 

Figure 27: selecting dates to include in a report 

Selecting the print settings: the final page of the wizard shows the number of pages your selections will 
produce and the current print settings, such as font, number of copies, colour printing and page layout for 
planner reports. You can also enable or disable QuickPrint and save the current settings as the default (see 
figure 28).  

Report settings may be set as follows: 

Copies: sets the number of copies to print, without changing the setting on your selected printer.  

Landscape/Portrait: select the orientation for this report. 
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Change font…: click to review or change the font settings for this report. 

Settings for planner reports only: set the number of weeks and lines (employees) per page, and also 
whether page breaks are required for departments and/or employee types. 

Print in colour: check to print all icons in colour. If a report is required to be faxed or photocopied, or no 
colour printer is available, uncheck this box to print icons as numbers (you will want to print a symbols key as 
well).  

Set as default: when checked, and the Print or Apply button is clicked, all the above settings are saved as 
the default print settings, which will be used for printing instant reports from the menu or toolbar. Memorised 
reports may also be set to use the default print settings. These settings are personal to each user and are 
saved to the INI file. 

Enable QuickPrint: check to allow a selected memorised report to be printed instantly from the  button on 

the toolbar. When unchecked, the toolbar instead displays the   button, which opens the print wizard. 

Print symbols key: you can choose to print a one-page symbols key with the report; this is most useful with 
a planner printout, which shows the symbols in grid form without a description, and is essential when not 
printing in colour, as planner symbols are shown only by a key number. If you are printing multiple copies, you 
may also print a symbols key for each copy of the report. 

Memorise: click to save the current report settings as a memorised report, or to resave the current 
memorised report. You will be asked to specify a name for a new report; for existing reports, changing the 
name will save the report details as a new memorised report. 

Printer…: click to choose a different printer. 

Print sample: for reports of more than one page, this button will print the first page to allow you to check the 
settings. 

 

Figure 28: selecting print options for a report 

Printing instant reports 

Many reports can be printed immediately without opening the print wizard. The QuickPrint option allows your 
favourite report to be printed with a single click on the toolbar. All memorised reports can be printed instantly 
from the menu, and a range of common reports can also be generated from the menu. The last report printed 
can be reprinted immediately. 

Because some instant reports are memorised, occasionally a problem will occur when attempting to print; for 
example, you may have deleted a name specified in the selection criteria, or you may have changed the 
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planner date range and the report dates are no longer appropriate. In such cases, Master Planner will fix the 
problem and ask you if you still want to print the report. You can check the new settings by viewing the report 
in the print wizard (select Print from the File menu, and select the Print a memorised report option). The 
fixed report will not be saved until the planner file is saved or AutoSaved. 

QuickPrint 

QuickPrint allows an instant report to be printed by a single click on the toolbar. By default, the QuickPrint 
report is a printout of all names on the current section of the planner, using default print settings (the first 
memorised report), but any memorised report may be set as your QuickPrint report.  

Enable QuickPrint by selecting Print on the File menu to open the print wizard. Select Set default print 
options and click Next. Tick the Enable QuickPrint option and click Apply. The print toolbar button on the 

main toolbar will now change to . 

To select a memorised report as your QuickPrint report, select Print on the File menu to open the print 
wizard, and select the Print memorised reports option. Your memorised reports will be displayed; click to 
highlight the required report, then check the QuickPrint box. See the section Memorised Reports below for 
details on how to set up memorised reports. 

To use QuickPrint, simply click the  button on the toolbar. Your chosen report will immediately be printed 
using the specified settings. The default QuickPrint report uses the current planner position as the basis for 
the report; for this report, be sure to position the planner to the required date before printing (the first date to 
be included in the report will be the date of the leftmost week visible on the planner). 

Note that QuickPrint settings are personal and are saved to the configuration file (mastplan.ini); each user 
may enable or disable QuickPrint and specify a QuickPrint report independently. Memorised reports, 
however, are saved as part of the planner file and, for network files, are available to all users. 

Print notes 

The Print selected notes section of the File menu shows a range of pre-determined options for printing 
notes, which will be printed using the current default print settings. The options available are: 

  Today 
  Last week 
  This week 
  Next week 
  Last month 
  This month 
  Next month 
  All past (includes today) 
  All future (includes today) 

Use the print wizard to print notes for other date ranges, or to change the print settings (select Print from the 
File menu). 

Print a personal schedule 

Highlight a name on the planner names list by clicking it; the File menu will now show an option to print an 
instant personal schedule, showing both icons and notes, for that employee, either for the current week or 
next week. The report prints using the current default print settings. Open the print wizard to print multiple 
schedules selected by name, department or employee type, or to use different dates, or to change the print 
settings (select Print from the File menu). 

Print a symbols key 

Select the Print a symbols key from the File menu to print an instant report of all symbols currently on the 
toolbar (whether in use or not) using the current default print settings. Open the print wizard to print a symbols 
key along with a report, or to change the print settings (select Print from the File menu). 
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Print a memorised report 

Prints a previously saved report, using the specified settings. Planner printouts, notes, personal and weekly 
schedules and statistics reports may all be memorised. The planner view to use and print settings may be 
specified individually for each memorised report. A memorised report may be printed from the print wizard or 
from the File menu. In addition, one memorised report may be set as your QuickPrint report (see above), 
which may be printed with one click from the toolbar. Open the print wizard to view or change memorised 
planner, personal schedule and notes reports, or to change the print settings (select Print from the File 
menu). Open the statistics screen to change memorised statistics reports (select Statistics from the Options 
menu). 

Reprint the last report printed 

Reprints immediately using the previous settings. Details of the last report you printed in the current session 
of Master Planner are retained, including selection criteria and print settings; this information is lost when you 
close the program down. This is useful if a printer problem occurs, you wish to memorise the report after 
printing or you wish to reprint with minor modifications. The last report printed may be accessed in the print 
wizard, where it may be modified, memorised and/or reprinted (select Print from the File menu). For 
statistics reports, memorise in the print wizard first, then open the statistics screen to modify (select 
Statistics from the Options menu). 

Default print options 

The default print options include the font settings (font name, size, bold and italic), printer orientation 
(landscape or portrait), number of copies and whether to print in colour or not. In addition, some settings 
apply only to planner printouts: lines per page, weeks per page, page break per department and page break 
per employee type. These settings are used for reports printed directly from the planner screen menu.  

View or change the default print options from the print wizard; select Print from the File menu, select Set 
default print options and click Next. Make any changes and check the Set as default box. Click Apply to 
save your changes. 

You can also change the default print options while composing a report in the print wizard; simply check the 
Set as default box to save your settings before clicking the Print button. 

Memorised reports may use the default print settings or may have their own settings. You can override the 
specified settings for a memorised report by opening it in the print wizard, changing print settings and clicking 
the Print or Print now button. 

Memorised reports 

Any report (planner, notes, personal or weekly schedules or statistics) can be memorised with all selections 
and settings for easy reprinting. Reprints may be set to use the full planner or the current view (or, for local 
files only, a personal view), and either the original printer settings or the current defaults.  

All memorised reports normally reprint using the exact dates specified originally. However, a planner report 
may either be set to use specified exact dates, or may print the currently visible section of the planner. Also, 
reports of notes using all future, all past or today’s dates will always reprint using the current date.  

For network planner files, the planner must be open for editing (with the green traffic light showing) before 
memorised reports may be saved, changed or deleted. However, any user may print a memorised report, or 
modify a memorised report in order to print a similar report. 

Any memorised report may be specified as the QuickPrint report, for instant printing from the toolbar 
(QuickPrint settings are personal to each user). 

Creating a memorised report 

To create a memorised planner, notes or personal or weekly schedule report, open the print wizard by 
selecting Print from the File menu. Select the required report type, and select the names or 
departments/employee types, dates and report options you require. On the report options wizard page, click 
the Memorise button to give your report a name and save all settings. You can now print the report or close 
the print wizard. 
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To create a memorised statistics report, open the statistics window by selecting Statistics from the 
Options menu. Select the icon, names, dates, options and print settings you require. Now click the 
Memorise button to give your report a name and save all settings. You can now print the report, view further 
statistics or close the statistics window. 

By default, a memorised report will be set always to use the exact print settings originally specified, and 
planner reports will use the exact date range of the original report. However, any memorised report can be 
set to use the default print settings, and planner reports may be set to print the currently visible section of the 
planner; see the section Changing a memorised report below for details on how to change these settings. 
Reports of notes using all future, all past or today’s dates will always reprint using the current date.  

Changing a memorised report 

To change a memorised planner, notes or personal or weekly schedule report, open the print wizard by 
selecting Print from the File menu. Select Print a memorised report, click Next and select the report to be 
changed.  

You can change the following options: 

View to use: determines which view to use for this report. Select from the full planner or the current view; for 
local files, personal views may also be selected. If a selected view is not available when the report is printed, 
the current view will be used. 

Use default print settings: leave unchecked to use the exact settings set for the original report; check to 
use the default font and report options (for example, lines and weeks per page on planner reports, whether to 
print in colour, and so on). These values are stored in your local INI file, and are therefore personal to each 
user. Network version users should note that to ensure a company standard on Master Planner reports, the 
font and report options should be specified explicitly in memorised reports rather than using default settings. 

QuickPrint: check to set this report as your QuickPrint report for this planner, which, if QuickPrint is enabled, 

may be printed instantly by clicking the  button on the toolbar. Enable QuickPrint by checking the box on 
the final page of the print wizard. Note that QuickPrint settings are personal to each user. 

Use exact dates (planner reports only): check to use the exact dates specified. Leave unchecked to use 
the current planner position at the time of printing. 

In addition, the selections, dates and font and report options may also be changed by clicking the Next and 
Back buttons, exactly as when creating a report. 

You can print the report at any time using the changed settings by clicking the Print now button, or by 
clicking Print on the final wizard page. To save changes to the memorised report, click the Memorise button. 
To save the changes as a new report, change the report name after clicking the Memorise. You will be 
prompted to save any unsaved changes before closing the print wizard, switching to a different memorised 
report or leaving the memorised reports options page. 

To change a memorised statistics report, open the statistics screen by selecting Statistics on the 
Options menu. Select the required memorised report from the drop-down list and click Open.  

You can make any changes you require on the icon, selection, dates, option and printing tabs, then click the 
Memorise button to resave. You can also specify this to be your QuickPrint report and set the report to use 
default or specified printer settings; these two settings may also be changed in the print wizard. To save the 
changes as a new report, change the report name after clicking the Memorise button. 

Deleting a memorised report 

To delete a memorised report, open the print wizard by selecting Print from the File menu. Select Print a 
memorised report, click Next and select the report to be deleted. Click the Delete button. Memorised 
statistics reports may also be deleted from the statistics screen (select Statistics from the Options menu). 

Note that the first memorised report (named ‘Instant planner print’) cannot be deleted or modified (other than 
print settings); this ensures that this option is always available as a QuickPrint report even when no other 
memorised reports have been created.
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Section 5: Changing planner settings 
Changing the planner names and displayed title 

To change the names assigned to the planner, select File details from the Options menu. Change the 
names as required. To change the information displayed on the Master Planner title bar, click Next, then 
Next again to reach the title bar options. The choices are: current year; planner name 1; planner name 2; 
planner file path. Make your selection and then click Finish.  

Changing the date range of the planner 

When you have used a standard style planner for a number of weeks, you may want to remove out-of-date 
weeks or add additional weeks to the end of the planner. In this way, a planner can be used indefinitely. You 
can also switch between a standard style planner, a calendar year style or a fixed date style (where you can 
specify exact start and end dates). 

To change the date range or style of a planner, select Options then Date range on the menu bar.  

For a standard style planner, indicate how many weeks you want added to or subtracted from the start or end 
of the planner (see figure 29). 

 

Figure 29: changing the size of a standard style planner 

For a calendar year planner, select the year for the adjusted planner (see figure 30). 
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Figure 30: changing the year for a calendar year planner 

For a fixed date planner, use the pop-up calendar to select the required dates (see figure 31). 

 

Figure 31: changing the dates on a fixed date planner 

Select the required style and settings. Click the Restart button to reset all values to their original positions. 
The New planner dates box shows the start and end dates according to your current selections. There is no 
need to retain any dates from the existing planner on the adjusted planner. A planner date range may be 
entirely in the future or the past, if required. 

Note that if you choose to remove some dates from the planner, you will lose all data on the planner for 
those dates. This means that any symbols or notes for those dates will be lost. 
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Check the Backup before changes option if you want the file backed up before making changes. If you have 
already specified a backup file path for the Quick Backup option, the backup will be carried out automatically. 
Otherwise, you will be shown the backup dialog window to select a backup file path. 

Click OK to carry out the specified changes. You will be shown a warning message if you have chosen to 
delete data from the file. If the AutoSave option is switched on, the changes will be saved when AutoSave is 
next activated; otherwise, the changes will not be saved until you request it. You will be prompted to save 
before opening a different planner or exiting the program. 

Changing the number of days in the week 

You can switch between 5 and 7 days in the planner week at any time. Click File details in the Options 
menu. Click Next to view the planner size and format page of the wizard, and select the required number of 
days (you cannot change other values on this page). Click Next and then Finish.  

Note that if you change from 7 to 5 days per week you will lose all data on the planner for Saturdays and 
Sundays; you will be asked to confirm this choice. 

Changing the daily time periods 

When you first create a planner, you can choose how many time periods you want to show for each 
employee per day. The default choice is 2 (for morning and afternoon) but you can choose to show up to 12. 

After a while, you may find that you want to change your choice, or change the descriptions, which are used 
when notes are displayed. To do this, select Options then Daily time periods from the menu. Bear in mind 
that the more time periods you show, the fewer employees can be viewed on screen at a time. The time 
periods you choose need not correspond to actual work shifts. 

 

Figure 32: adding a new daily time period 

To change time period descriptions: click Copy all to copy all existing time periods to the new 
arrangement, type the new descriptions in the white boxes and click OK. 

To add or remove time periods: copy an existing time period to the new arrangement by selecting it by 
clicking, then click Add. Add a new time period by clicking Add new. If you make a mistake, you can remove 
a time period from the new list by clicking the Remove button (click to select it first) or click Restart to restore 
the original settings. Type any changes of description in the white boxes. When satisfied, click OK.  
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Note that when you omit an existing time period from the new arrangement, you will lose all data on the 
planner for that time period. Also, when you add a new time period to the planner, it will show no data 
(other than icons applicable to entire columns and employee non-availability). However, you can copy an 
existing time period (and its data) more than once, for example, if you want to split an existing time period into 
two parts (such as AM into early and late morning), but retain the existing planner icons for both. 

Changing the default planner file 

Master Planner opens the default planner file automatically when it loads from information stored in the 
initialisation file (mastplan.ini). To change your default file, first open the file you want to be your default, then 
click Preferences in the Options menu, and select the Startup tab. Check the Make this planner the 
default startup file option.  

Note that this setting may be overridden if Master Planner is opened by a shortcut with a command-line (see 
the section Opening a planner file with a command-line, in How to use Master Planner, above, for full 
details). 

Changing the way Master Planner opens 

Master Planner normally opens the way you left it. To ensure it always opens minimised to the system tray, 
click Preferences in the Options menu, and select the Global tab. Check the Show program icon in 
system tray option. Note that this setting applies to all planners and all instances of the program, and 
overrides any other options set for individual planners. 

If you have not set the global system tray option, you can choose to open a specific planner minimised to the 
task bar or minimised to the system tray by using a shortcut with a command-line (see the section Opening a 
planner file with a command-line, in How to use Master Planner, above, for full details). 

To ensure that a specific planner opens when Windows starts, click Preferences in the Options menu, and 
select the Startup tab. Check the Automatically run this planner when Windows starts option, and select 
whether the program should start normal size, minimised to the task bar or minimised to the system tray. This 
information is saved to the registry; you may need administrators rights to set this option. See your network 
administrator or IT advisor if you need help with this. 

Changing the save location 

When you first create and save a planner, you specify where on the available drives you would like it saved. 
Normally, you would move files using Windows explorer, but for a planner specified as the default or with 
personal views defined or set to run automatically when Windows starts, this method is not recommended. 

If you have set AutoRun for this planner, you should switch this option off by selecting Preferences from the 
Options menu and clicking the Startup tab. Ensure that the option Automatically run this planner when 
Windows starts is unchecked. Some versions of Windows require administrators rights to change this 
setting.  

Next, you should use the Save as option on the File menu to create a copy of your planner in the new 
location. Your personal views will automatically be retained for the new file. Set the new file to the default (if 
required) by selecting Preferences on the Options menu, and clicking the Startup tab. You can also set the 
new file to run automatically when Windows starts on this tab. The file in the old location may now be 
removed to backup storage or deleted. 

Users accessing network files should ask their network administrator to move files. 
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Section 6: Customisation 
Changing planner date column headings 

Specify the column headings you prefer by clicking Preferences on the Options menu, and clicking the 
Dates tab (see figure 33). Your choices apply to all planners you view. 

Date format: shows either the start date of the week (in the form 24 Sep 2001 or Sep 24, 2001 depending on 
your computer’s settings) or the week number (in the form 2001/Week 31). Bear in mind that Week 1 of the 
year is the week in which January 1st occurs and that there may be more than 52 weeks in a year. 

 

Figure 33: changing the planner date column headings 

Changing colours 

Specify the colours you prefer by clicking Preferences on the Options menu, and clicking the Colours tab 
(see figure 34). Your choices apply to all planners you view. You can choose from a range of pale or darker 
colours or white for these settings: 

Names/dates: affects the list of employee names to the left of the planner, and the dates displayed above the 
planner. Text on these areas is displayed in a contrasting colour. 

Vertical grid blocks: shows a band of your preferred colour to mark alternate weeks (if the planner has 5 
days in a week) or to mark weekends (for a 7 day planner). Select white to turn this option off. 

Horizontal grid blocks: displays alternate employees in your preferred colour. Select white to turn this option 
off. 

Grid selection: shows the highlighted area of the grid selected by mouse in your preferred colour. 
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Figure 34: changing the colours 

Changing startup options for a planner 

Specify the options you prefer by clicking Preferences on the Options menu, and clicking the Startup tab 
(see figure 35). Your choices apply to this planner only.  

Make this planner the default startup file: if checked, this planner will be opened automatically when you 
start Master Planner. Note that this setting may be overridden if Master Planner is opened by a shortcut with 
a command-line (see the section Opening a planner file with a command-line, in How to use Master 
Planner, above, for full details), or by an AutoRun setting (see below). 

Automatically run this planner when Windows starts: select whether the program should start normal 
size (as you left it), minimised to the task bar or minimised to the system tray. This information is saved to 
the registry; you may need administrators rights to set this option. See your network administrator or IT 
advisor if you need help with this. 

Start this planner in this view: if you have specified personal views, you can choose to open this planner in 
a specific view. To create personal views, select Edit personal views from the Views menu; personal views 
enable you to select only those departments and/or employee types of interest to you. 

Changing the recent files list 

Remove unwanted items from the recent files list by clicking Preferences on the Options menu, and clicking 
the Files tab (see figure 36). Removed items will no longer appear on the list of recent files on the Files 
menu or open file dialog. The actual files will still exist on your local or network drive. 
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Figure 35: changing startup options for a planner 

 

Figure 36: updating the recent files list 
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Changing global options 

Specify the options you prefer by clicking Preferences on the Options menu, and clicking the Global tab 
(see figure 37). Your choices apply to all planners you view. 

Show program icon in system tray: if checked, Master Planner will always open minimised to the system 
tray. Note that when run from the system tray, the program can only be closed from the system tray context 
menu; closing the program window returns it to the system tray. This option applies to all planners and all 
instances of the program. 

Warn me when overwriting existing icons on planner: if checked, you will be asked to confirm if you are 
attempting to add icons to the planner on a selected area which already includes some icons. This is useful if 
you know that you will rarely want to change icons already on a planner. This warning does not apply if you 
are deleting icons from an area, whether using the toolbar button, the Delete key, the Clear row or Clear 
column options or the Undo function. 

Autosave: an option which enables a planner to be saved automatically. The current AutoSave setting is 
saved in the configuration file (mastplan.ini) and applies to all planners you open for which you have editing 
rights (for network files, the AutoSave option will only be active while the file is open for editing). When a 
planner is automatically saved, a message will be shown in the right portion of the status bar below the 
planner. There are 5 settings: 

Off: the planner will only be saved when you request it (you will be prompted to save any unsaved changes 
before opening a different planner or exiting the program). 
Save on exit: the planner will automatically be saved when opening a different planner or exiting the program 
(you will not be prompted). 
Save on change: any changes you make will be saved immediately. 
Save every 5 minutes: the planner will automatically be saved every 5 minutes. 
Save every 1 minute: the planner will automatically be saved every minute. 

 

Figure 37: changing global user options 

Toolbar style: applies to the main toolbar and the two floating toolbars (planner symbols and editing) in all 
planners you view. Select from Internet Explorer style (normally flat, raised when mouse hovers), Windows 
95 style (raised) or, for retro fans, Windows 3.x style (heavy 3D). 
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Adding or removing icons on the symbols toolbar 

Open the toolbar icons editing dialog by selecting Edit toolbar icons from the Edit menu or clicking the  
button on the edit toolbar. You can now see your existing toolbar, plus a range of alternatives arranged on 
tabs (see figure 38). Network version users may also access a previously-created file of custom icons on the 
Custom tab. 

 

Figure 38: customising the planner toolbar 

Adding an icon: drag it from the tab and drop it on the toolbar. You will not be able to do this for icons 
already on the toolbar. You can drop into any position, or drag it to a new position. To change the description 
of a symbol or make it apply to an entire column, click on it on the new toolbar and edit the Change the 
selected icon box.  

Icons which apply to an entire column are used for those activities or events which always apply to all 
employees, such as a bank or company holiday, company-wide meetings or the office party; when added to 
the planner, they will fill all selected columns, not just the selected area. To delete them from the planner, use 
the Clear column option from the Edit menu. 

Removing an icon: drag it from the toolbar and drop it onto an empty area of the window, such as the space 
below the toolbar. You will not be able to do this for icons which are currently in use on the planner, you must 
delete all occurrences of the icon from the planner first (use the Statistics feature from the Options menu to 
trace usages of the icon). 

Custom icons displayed as : this indicates that the file for this custom icon cannot be found in the 
expected location. When a planner is opened, the program will search for missing custom icon files, but the 
toolbar editing dialog will flag them as missing to indicate a possible problem. To fix this problem, open the 
custom icons data file by selecting Custom icon management from the Options menu, and use the 
Browse button to search for missing custom icon files (see the section Creating your own icons, below). 

Your changed toolbar can be saved to be used in other planners (tick the Save toolbar option; Network 
version users may also select a save location for the file). If you choose not to do this, the toolbar will be 
saved as part of the planner and used only for this planner.  

Saving a toolbar 

After adding or removing icons or changing descriptions, your changed toolbar can be saved to be used in 
other planners. To do this, tick the Save toolbar option. For Standard version users, the toolbar will be saved 
under the name “mastplan.tlb” in the same directory as the program; only one toolbar file may be saved. 
Network version users may select a save location for the file, and may save any number of toolbar files. If you 
choose not to save it, the toolbar will be used only for this planner and stored as part of the planner file. 
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To reuse your saved file with an existing planner, open the planner you wish to use the toolbar with, and open 
the toolbar icons editing dialog (select Edit toolbar icons from the Edit menu). Now click the Import  
toolbar button. Network version users will be asked to browse for the required file. The imported toolbar file 
will entirely replace the existing toolbar, whether or not icons are in use. Any icons on the planner not 
matching an icon on the new toolbar will display the symbol . 

To reuse your saved file with a new planner, select New from the File menu and follow the steps in the 
wizard. You will be able to import the saved toolbar as part of the new file setup. 

Creating your own icons (Network version only) 

Network version users can create their own custom icons for use in planner toolbars. There are 3 steps 
required: 

Step 1 – Create the icons.  

You will need to use a standard drawing package capable of producing bitmap (.bmp) files, such as Windows 
Paint or Paint Shop Pro. It is recommended that you use the standard Windows 16-colour palette. 

You will need to create 2 bitmap files for each icon: a toolbar bitmap (20 pixels x 20 pixels) and a planner grid 
bitmap (18 pixels wide x 10 pixels high). The toolbar icon displays as transparent the colour found in the pixel 
on the bottom row, second from the right; the grid icon does not use transparency. 

Save each icon to a location where they will be readily available to any planner file which will be using them 
(such as the same directory as the planner file). 

Step 2 – Compile a custom icon data file. 

Once you have created some icon bitmaps, you must compile them into a custom icon data file for importing 
into a planner. This is simply a list of the custom icons, specifying the path where they can be found, and 
some other details, in a form readable in the program. 

In Master Planner, select Custom icon management from the Options menu, and click the Create a new 
custom icon file option on the File tab, using the Browse  button to set a file path. 

 

Figure 39: compiling details of custom icons 

On the Custom icons tab (see figure 39), use the Browse buttons to locate each pair of icons, and choose a 
suitable colour for the flash to indicate a note. Add a description and select a 2-letter code for the icon (these 
are arbitrary values used internally by Master Planner to identify each icon). Click Add to add the icon to the 
Custom Icons toolbar. Note that the description you add here is only an indication – when the icon is added 
to a planner toolbar, the final description will be set at that time. 
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If you make a mistake, you can drag an icon off the toolbar. To modify your settings, click the icon and make 
any changes. You cannot change the arbitrary code without removing the icon from the toolbar and adding it 
back with a different code. 

Click OK to save the list of icons as a data file. The OK button is only enabled once you have specified a file 
path on the File tab and added at least one icon to the Custom icon toolbar.  

Step 3 – Add the custom icons to a planner file. 

The custom icon data file is now available to any Master Planner user and enables custom icons to be added 
easily to a planner. 

Select Edit toolbar icons from the Edit menu, and click the Custom tab. Click the Browse button on the tab 
to search for the custom icon data file you have just compiled; all the icons in it are shown on the tab, and 
may be dragged onto the toolbar, exactly as with the built-in icons (see figure 40). The path of the custom 
icon data file will be saved with the planner data, so that all users have access to it when editing a planner 
toolbar. 

 

Figure 40: customising the planner toolbar 

You can create as many custom icons and associated data files as you wish. Note that the custom icon data 
file is only a list of available custom icons and their locations, and is only needed when the toolbar is edited. It 
is not required for normal day-to-day running of Master Planner. If you use custom icons, it is recommended 
that you save the toolbar file separately from the planner data (check the Save this toolbar to use with 
other planners option), so that you can use your normal network software to restrict editing privileges (if the 
toolbar is not saved separately, any user with editing access to the planner can also edit the toolbar). 

Note that once a custom icon is added to the toolbar of a planner file, the paths of the bitmaps for the toolbar 
and grid images are stored as part of the planner or toolbar file, therefore they need to be available whenever 
Master Planner runs. This is particularly important for users who may wish to run the program away from the 
network; in such cases, you should ensure that the custom icon bitmaps and the toolbar file are saved to the 
user’s local hard drive in the same directory as either the planner file or the Master Planner executable, as 
the program will search these locations for any missing files.  
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Section 7: Troubleshooting 
Using the help file 

This booklet is designed to help you install Master Planner and learn to use it, but the program is also 
supplied with a comprehensive help file. This contains full details of every screen you will encounter, an 
extensive How do I…? Section, troubleshooting tips and much more. To access the help file: 

1) Click Help on the menu bar of the main planner screen; or 

2) Click the Help button shown on other screens to obtain context-sensitive help; or 

3) Press the F1 button at any point to obtain context-sensitive help; or 

4) On your Windows Start Menu, in the Programs section, under Master Planner, you can open the help 
file without running Master Planner. 

Contacting technical support 

If you encounter problems while installing or using Master Planner, you can get the latest information, 
including details of all known problems, from the Ross Software web site at: 

www.ross-software.co.uk 

Full technical support will be available to registered users (please quote your customer number if possible). 
Correspondence is also welcome from demo version users. Send all comments, suggestions, enquiries and 
problem reports to Ross Software giving as much detail as possible, for example, size and type of machine, 
operating system, any error messages encountered and size of planner. Contact us: 

By email 

pmross@ross-software.co.uk 

By mail 

Ross Software, 15 Meadow Way, Rowledge, Farnham, Surrey, GU10 4DY, UK 

By phone (UK office hours only, please) 

+44 (0)1252 795169 
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Section 8: Registration and upgrading 
Master Planner is available direct from Ross Software or for download from our website at www.ross-
software.co.uk The supplied version is the same for registered users and those wishing to evaluate the 
program prior to purchase. Registered users are supplied with a registration key to unlock all the features of 
the program. Without the registration key, the program runs in unregistered mode, which has some 
limitations. 

Versions available 

The demo (unregistered) version 

The demo version of Master Planner 3 is available as shareware for evaluation purposes. There are some 
restrictions on the demo version: 

Only one 30 week standard style planner, not extendable, with no more than 20 names on the planner 

Only one user (not network compatible) 

Backup, restore, statistics and icon customisation functions not available 

Reports print with “DEMO” across each page 

Reminder screen on startup after 4 weeks 

There is no time limit or restriction on the number of uses of the program. 

To obtain the unrestricted version, you will need to register by email, phone or mail or online at our website 
www.ross-software.co.uk and pay a fee. 

The standard version 

The Standard version of Master Planner can only be run on a stand-alone machine or laptop computer (not 
on a network server). It is ideal for small to medium sized companies where only one or two people need to 
access employee information regularly. It may also be used by department heads or project leaders to keep 
track of their own staff. You must purchase one copy of Master Planner Standard for each machine on which 
the software is to be installed. If you have more than 3 users at one location, you should purchase the 
Network version with the appropriate number of user licences. 

The network version 

The Network version of Master Planner is fully network compatible for those companies which require to 
make Master Planner available to a larger range of staff, although this version may also be installed on stand-
alone machines for individual use. The application software and/or files may be stored on the server, bringing 
them into the company’s usual security and backup procedures. All staff with access to the network can thus 
view Master Planner files. Use your network software to make Master Planner files fully accessible, read-only 
or not available to individual staff. Master Planner will then disable editing functions for those with read-only 
access. 

In addition, the Network version allows full customisation of the planner toolbar, allowing you to use your own 
design of planner symbols, and multiple toolbar (icon set) files may be created. 

The Network version is available for 4, 10, 20, 50 and unlimited users at one location (other numbers of users 
available on request). Any user may access the program on the network or as a stand-alone installation. 

User licencing 

Master Planner is not sold on a per-copy basis. Instead, licences are available for a single user or for 4, 10, 
20, 50 or unlimited users at a single location (other numbers of users available on request). Each licence 
permits one user to install Master Planner on one machine; a second installation per user to a laptop machine 
is permitted for use outside the office. A user is anyone who views, updates or prints Master Planner files. 
You must purchase Master Planner separately for each location where it is installed. 



Registration 

Page 59 

The end-user licencing agreement is printed on the Master Planner Registration Certificate (supplied 
following receipt of payment) and also on the CD cover, or will be supplied at any time on request. 

Prices 

Master Planner may be purchased in two versions: 

Standard (single-user) version 

Network version - available for 4, 10, 20, 50 or unlimited users at one location (other numbers of users 
available on request) 

Check our website at www.ross-software.co.uk for the latest prices or phone us on +44 (0)1252 795169 
Registered users who upgrade from the Standard to the Network version, or increase the number of licenced 
network users, pay only the difference between the prices of your existing version and the new one. If you 
require a different number of network users, ask for a quotation. 

Our prices include all applicable UK taxes. If you request a backup disk and a manual, these will be sent free 
of charge at the time of purchase; the program and manual may also be downloaded from our website. 

For customers outside the UK, we can quote in any major currency; quotes are valid for one month. You may 
be liable for local or import taxes. 

How to register or add additional users 

To register or upgrade Master Planner, or add additional Network version users, contact us with your 
requirements by one of the methods below and we will give you a temporary (time-limited) registration key to 
unlock all the features of Master Planner in your chosen version. We will then invoice you at current prices for 
processing through your accounts department in the usual way.  

When we receive your payment, we will send you a permanent registration key. Our normal purchase method 
is electronic, as the program and manual are available for download from our web site; all you pay for is the 
registration key. However, if requested, we will also send you the program on disk, and a bound copy of the 
manual. 

Online order  

Visit the Ross Software web site at www.ross-software.co.uk and complete the online order form. This will 
be dispatched to us and we will reply by email, usually within 24 hours, confirming your order and the current 
price, and giving you a temporary registration key to unlock all the features of Master Planner. When we 
receive your payment, we will send you a permanent registration key. 

By e-mail 

E-mail Ross Software at sales@ross-software.co.uk, telling us your name, company name and address, 
purchase order number (if applicable) and the version required, plus the currency you wish to be invoiced in 
(if not UK pounds). We will reply, usually within 24 hours, confirming your order and the current price, and 
giving you a temporary registration key to unlock all the features of Master Planner. When we receive your 
payment, we will send you a permanent registration key. 

By fax 

Fax us on +44 (0)1252 795169 telling us your name, company name and address, purchase order number (if 
applicable) and the version required, plus the currency you wish to be invoiced in (if not UK pounds). We will 
reply, usually within 24 hours, confirming your order and the current price, and giving you a temporary 
registration key to unlock all the features of Master Planner. When we receive your payment, we will send you 
a permanent registration key. 

By phone  

Phone Ross Software on +44 (0)1252 795169. We can give you a temporary registration key immediately to 
unlock all the features of Master Planner. When we receive your payment, we will send you a permanent 
registration key. 
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By mail  

Print and complete the registration form from the help file and send with your cheque to the address shown. 
We will send you the permanent registration key by mail.  

Obtaining interim upgrades 

The latest version of Master Planner 3 is available for download from our website at www.ross-
software.co.uk This will include the latest bug-fixes as well as interim version upgrades (such as 3.1, 3.2, 
etc) with enhanced functionality. These upgrades are free to all users of Master Planner 3. You can download 
either the full setup program (approx 2.7Mb) or just the program itself (approx 1Mb). The upgrades will read 
the existing registration data for registered users. 

You can also download the latest version of this manual and a one-page QuickGuide, supplied in Adobe pdf 
format. 


